r3219: *** empty log message ***
[reversi.git] / -clim / debian / rules
diff --git a/-clim/debian/rules b/-clim/debian/rules
new file mode 100755 (executable)
index 0000000..f61802c
--- /dev/null
@@ -0,0 +1,61 @@
+#!/usr/bin/make -f
+
+export DH_COMPAT=4
+
+pkg    := cl-reversi-clim
+
+
+configure: configure-stamp
+configure-stamp:
+       dh_testdir
+       # Add here commands to configure the package.
+
+       touch configure-stamp
+
+
+build: build-stamp
+
+build-stamp: configure-stamp 
+       dh_testdir
+       # Add here commands to compile the package.
+       lw-console -init lw-build-exec.lisp
+       touch build-stamp
+
+clean:
+       dh_testdir
+       dh_testroot
+       rm -f build-stamp configure-stamp
+       # Add here commands to clean up after the build process.
+       rm -f debian/cl-reversi-clim.postinst.* debian/cl-reversi-clim.prerm.*
+       dh_clean
+
+install: build
+       dh_testdir
+       dh_testroot
+       dh_clean -k
+       # Add here commands to install the package into debian/reversi.
+       dh_installdirs usr/bin
+       dh_install cl-reversi usr/bin
+
+# Build architecture-independent files here.
+binary-indep: build install
+
+
+# Build architecture-dependent files here.
+binary-arch: build install
+       dh_testdir
+       dh_testroot
+       dh_installdocs
+       dh_installchangelogs
+       dh_installman -p $(debpkg-clim) debian/cl-reversi.1
+       dh_strip
+       dh_compress
+       dh_fixperms
+       dh_installdeb
+       dh_shlibdeps
+       dh_gencontrol
+       dh_md5sums
+       dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install configure