r2905: *** empty log message ***
[uffi.git] / debian / rules
index 54c3210e2db892290e69aa9fba4b679890e209ef..1148184efd6f04f77363c3f943f7555a545a0c86 100755 (executable)
@@ -1,28 +1,17 @@
 #!/usr/bin/make -f
-# Sample debian/rules that uses debhelper.
-# GNU copyright 1997 to 1999 by Joey Hess.
 
-# Uncomment this to turn on verbose mode.
-# export DH_VERBOSE=1
-
-# This is the debhelper compatibility version to use.
 export DH_COMPAT=4
 
 pkg    := uffi
 debpkg  := cl-uffi
-prefix := debian/$(debpkg)
 
-INSTALL        := install
-INSTALLFLAGS   := -g root -o root -m 0644
-INSTALLDIRFLAGS        := -d -g root -o root -m 0755
 
-SOURCEDIR      := $(prefix)/usr/share/common-lisp/source/${pkg}
-DOCDIR         := $(prefix)/usr/share/doc/${debpkg}
+clc-source     := usr/share/common-lisp/source
+clc-systems    := usr/share/common-lisp/systems
+clc-uffi       := $(clc-source)/$(pkg)
 
-UPSTREAM_VER   := $(shell sed -n -e "s/${debpkg} (\(.*\)-[0-9.]).*/\1/p" < debian/changelog |head -1)
+doc-dir                := usr/share/doc/$(debpkg)
 
-pkg-ver                := $(debpkg)-$(UPSTREAM_VER)
-clc-source     := $(SOURCEDIR)-$(UPSTREAM_VER)
 
 configure: configure-stamp
 configure-stamp:
@@ -38,8 +27,6 @@ build-stamp: configure-stamp
        dh_testdir
 
        # Add here commands to compile the package.
-       # Make doc isn't necessary because the docs are in the upstream version
-       # $(MAKE) doc
 
        touch build-stamp
 
@@ -58,19 +45,21 @@ install: build
        dh_testdir
        dh_testroot
        dh_clean -k
-       dh_installdirs
+       dh_installdirs --all $(clc-systems) $(clc-source) 
+       dh_installdirs -p $(debpkg) $(doc-dir) $(clc-uffi)/src
 
        # Add here commands to install the package into debian/uffi.
-       $(INSTALL) $(INSTALLDIRFLAGS) $(clc-source)
-       $(INSTALL) $(INSTALLDIRFLAGS) $(clc-source)/mcl
-       $(INSTALL) $(INSTALLFLAGS) $(shell echo src/*.cl *.system) $(clc-source)
-       $(INSTALL) $(INSTALLFLAGS) $(shell echo src/mcl/*.cl) $(clc-source)/mcl
-       $(INSTALL) $(INSTALLFLAGS) doc/html/* $(DOCDIR)/html
+       dh_install uffi.asd $(clc-uffi)
+       dh_install "src/*.cl" $(clc-uffi)/src
+       dh_link $(clc-uffi)/uffi.asd $(clc-systems)/uffi.asd
+
+       rm -rf doc/html
+       (cd doc; tar xzf html.tar.gz; cd ..)
+       dh_install doc/html $(doc-dir)
+       rm -rf doc/html
        cp doc/uffi.pdf doc/cl-uffi.pdf
-       rm -f doc/cl-uffi.pdf.gz
-       gzip doc/cl-uffi.pdf
-       $(INSTALL) $(INSTALLFLAGS) doc/cl-uffi.pdf.gz $(DOCDIR)
-       rm -f doc/cl-uffi.pdf.gz
+       gzip -9 doc/cl-uffi.pdf
+       dh_install doc/cl-uffi.pdf.gz $(doc-dir)
 
 # Build architecture-independent files here.
 binary-indep: build install
@@ -97,7 +86,6 @@ binary-arch: build install
        dh_strip
        dh_compress
        dh_fixperms
-       dh_link $(clc-source) $(SOURCEDIR)
 #      dh_makeshlibs
        dh_installdeb
 #      dh_perl