r2905: *** empty log message ***
[uffi.git] / debian / rules
index a7d0713697bed5b4223af669e93bf35ed27acddf..1148184efd6f04f77363c3f943f7555a545a0c86 100755 (executable)
@@ -1,24 +1,16 @@
 #!/usr/bin/make -f
-# Sample debian/rules that uses debhelper.
-# GNU copyright 1997 to 1999 by Joey Hess.
 
-# Uncomment this to turn on verbose mode.
-# export DH_VERBOSE=1
+export DH_COMPAT=4
 
-# This is the debhelper compatibility version to use.
-export DH_COMPAT=3
+pkg    := uffi
+debpkg  := cl-uffi
 
-pkg    := cl-uffi
-prefix := debian/$(pkg)
 
-INSTALL        := install
-INSTALLFLAGS   := -g root -o root -m 0644
-INSTALLDIRFLAGS        := -d -g root -o root -m 0755
+clc-source     := usr/share/common-lisp/source
+clc-systems    := usr/share/common-lisp/systems
+clc-uffi       := $(clc-source)/$(pkg)
 
-SOURCEDIR      := $(prefix)/usr/share/common-lisp/source
-REPOSITORYDIR  := $(prefix)/usr/share/common-lisp/repositories/uffi
-SYSDIR         := $(prefix)/usr/share/common-lisp/systems
-DOCDIR         := $(prefix)/usr/share/doc/cl-uffi
+doc-dir                := usr/share/doc/$(debpkg)
 
 
 configure: configure-stamp
@@ -35,8 +27,6 @@ build-stamp: configure-stamp
        dh_testdir
 
        # Add here commands to compile the package.
-       $(MAKE) doc
-       #/usr/bin/docbook-to-man debian/uffi.sgml > uffi.1
 
        touch build-stamp
 
@@ -55,26 +45,26 @@ install: build
        dh_testdir
        dh_testroot
        dh_clean -k
-       dh_installdirs
+       dh_installdirs --all $(clc-systems) $(clc-source) 
+       dh_installdirs -p $(debpkg) $(doc-dir) $(clc-uffi)/src
 
        # Add here commands to install the package into debian/uffi.
-       cp $(SYSDIR)/uffi.system.debian $(SYSDIR)/uffi.system
-       chmod 0644 $(SYSDIR)/uffi.system
-       chown root.root $(SYSDIR)/uffi.system
-       $(INSTALL) $(INSTALLFLAGS) $(shell echo src/*.cl) $(REPOSITORYDIR)
-       $(INSTALL) $(INSTALLFLAGS) $(shell echo src/mcl/*.cl) $(REPOSITORYDIR)/mcl
-       $(INSTALL) $(INSTALLFLAGS) doc/html/* $(DOCDIR)/html
-       cp doc/uffi.ps doc/cl-uffi.ps
-       rm -f doc/cl-uffi.ps.gz
-       gzip doc/cl-uffi.ps
-       $(INSTALL) $(INSTALLFLAGS) doc/cl-uffi.ps.gz $(DOCDIR)
-       rm -f doc/cl-uffi.ps.gz
+       dh_install uffi.asd $(clc-uffi)
+       dh_install "src/*.cl" $(clc-uffi)/src
+       dh_link $(clc-uffi)/uffi.asd $(clc-systems)/uffi.asd
+
+       rm -rf doc/html
+       (cd doc; tar xzf html.tar.gz; cd ..)
+       dh_install doc/html $(doc-dir)
+       rm -rf doc/html
+       cp doc/uffi.pdf doc/cl-uffi.pdf
+       gzip -9 doc/cl-uffi.pdf
+       dh_install doc/cl-uffi.pdf.gz $(doc-dir)
 
 # Build architecture-independent files here.
 binary-indep: build install
 
 
-
 # Build architecture-dependent files here.
 binary-arch: build install
        dh_testdir
@@ -93,14 +83,13 @@ binary-arch: build install
 #      dh_installinfo
 #      dh_undocumented
        dh_installchangelogs ChangeLog
-       dh_link
        dh_strip
        dh_compress
        dh_fixperms
 #      dh_makeshlibs
        dh_installdeb
 #      dh_perl
-#      dh_shlibdeps
+       dh_shlibdeps
        dh_gencontrol
        dh_md5sums
        dh_builddeb