r2246: *** empty log message ***
[uffi.git] / debian / rules
index ab808511ddfb5c347d8f9c5835431cfcf16b950c..1b29e9b48c575fe2bb93477dde64023893541c9b 100755 (executable)
@@ -1,19 +1,10 @@
 #!/usr/bin/make -f
-# Sample debian/rules that uses debhelper.
-# GNU copyright 1997 to 1999 by Joey Hess.
 
-# Uncomment this to turn on verbose mode.
-# export DH_VERBOSE=1
-
-# This is the debhelper compatibility version to use.
 export DH_COMPAT=4
 
 pkg    := uffi
 debpkg  := cl-uffi
 
-INSTALL        := install
-INSTALLFLAGS   := -g root -o root -m 0644
-
 UPSTREAM_VER   := $(shell sed -n -e "s/${debpkg} (\(.*\)-[0-9.]).*/\1/p" < debian/changelog |head -1)
 
 pkg-ver                := $(debpkg)-$(UPSTREAM_VER)
@@ -61,7 +52,8 @@ install: build
        dh_installdirs -p $(debpkg) $(doc-dir) $(lispfiles)/mcl 
 
        # Add here commands to install the package into debian/uffi.
-       dh_install "src/*.cl" "*.system" $(lispfiles)
+       dh_install "uffi.system" $(clc-systems)
+       dh_install "src/*.cl" $(lispfiles)
        dh_install "src/mcl/*.cl" $(lispfiles)/mcl
 
        rm -rf doc/html
@@ -69,10 +61,8 @@ install: build
        dh_install doc/html $(doc-dir)
        rm -rf doc/html
        cp doc/uffi.pdf doc/cl-uffi.pdf
-       rm -f doc/cl-uffi.pdf.gz
-       gzip doc/cl-uffi.pdf
+       gzip -9 doc/cl-uffi.pdf
        dh_install doc/cl-uffi.pdf.gz $(doc-dir)
-       rm -f doc/cl-uffi.pdf.gz
 
 # Build architecture-independent files here.
 binary-indep: build install