r4699: *** empty log message ***
[uffi.git] / debian / rules
index 54c3210e2db892290e69aa9fba4b679890e209ef..36ea0d7c76a0d893e3fa4bd926dd39dfdfb6f409 100755 (executable)
@@ -1,34 +1,22 @@
 #!/usr/bin/make -f
-# Sample debian/rules that uses debhelper.
-# GNU copyright 1997 to 1999 by Joey Hess.
 
-# Uncomment this to turn on verbose mode.
-# export DH_VERBOSE=1
+pkg            := uffi
+pkg-tests      := $(pkg)-tests 
+debpkg         := cl-$(pkg)
+debpkg-tests   := $(debpkg)-tests
 
-# This is the debhelper compatibility version to use.
-export DH_COMPAT=4
 
-pkg    := uffi
-debpkg  := cl-uffi
-prefix := debian/$(debpkg)
-
-INSTALL        := install
-INSTALLFLAGS   := -g root -o root -m 0644
-INSTALLDIRFLAGS        := -d -g root -o root -m 0755
-
-SOURCEDIR      := $(prefix)/usr/share/common-lisp/source/${pkg}
-DOCDIR         := $(prefix)/usr/share/doc/${debpkg}
-
-UPSTREAM_VER   := $(shell sed -n -e "s/${debpkg} (\(.*\)-[0-9.]).*/\1/p" < debian/changelog |head -1)
-
-pkg-ver                := $(debpkg)-$(UPSTREAM_VER)
-clc-source     := $(SOURCEDIR)-$(UPSTREAM_VER)
+clc-source     := usr/share/common-lisp/source
+clc-systems    := usr/share/common-lisp/systems
+clc-files      := $(clc-source)/$(pkg)
+clc-tests      := $(clc-source)/$(pkg-tests)
+doc-dir                := usr/share/doc/$(debpkg)
+lib-dir                := usr/lib
 
 configure: configure-stamp
 configure-stamp:
        dh_testdir
        # Add here commands to configure the package.
-
        touch configure-stamp
 
 
@@ -36,41 +24,46 @@ build: build-stamp
 
 build-stamp: configure-stamp 
        dh_testdir
-
        # Add here commands to compile the package.
-       # Make doc isn't necessary because the docs are in the upstream version
-       # $(MAKE) doc
-
+       (cd examples; make linux)
        touch build-stamp
 
 clean:
        dh_testdir
        dh_testroot
        rm -f build-stamp configure-stamp
-
        # Add here commands to clean up after the build process.
        -$(MAKE) clean
-       rm -f debian/cl-uffi.postinst.* debian/cl-uffi.prerm.*
-
+       cd examples
+       make clean
+       rm -f debian/$(debpkg).postinst.* debian/$(debpkg).prerm.*
        dh_clean
 
 install: build
        dh_testdir
        dh_testroot
        dh_clean -k
-       dh_installdirs
+       dh_installdirs --all $(clc-systems) $(clc-source) 
+       dh_installdirs -p $(debpkg) $(doc-dir) $(clc-files)/src
 
        # Add here commands to install the package into debian/uffi.
-       $(INSTALL) $(INSTALLDIRFLAGS) $(clc-source)
-       $(INSTALL) $(INSTALLDIRFLAGS) $(clc-source)/mcl
-       $(INSTALL) $(INSTALLFLAGS) $(shell echo src/*.cl *.system) $(clc-source)
-       $(INSTALL) $(INSTALLFLAGS) $(shell echo src/mcl/*.cl) $(clc-source)/mcl
-       $(INSTALL) $(INSTALLFLAGS) doc/html/* $(DOCDIR)/html
+       dh_install $(pkg).asd $(clc-files)
+       dh_install "src/*.lisp" $(clc-files)/src
+       dh_link $(clc-files)/$(pkg).asd $(clc-systems)/$(pkg).asd
+
+       dh_installdirs -p $(debpkg-tests) $(clc-tests)/tests $(lib-dir)
+       dh_install $(debpkg-tests) $(pkg-tests).asd $(clc-tests)
+       dh_install $(debpkg-tests) "examples/*.lisp" $(clc-tests)/tests
+       dh_install $(debpkg-tests) "examples/c-test-fns.so" $(lib-dir)
+       dh_link $(debpkg-tests) $(clc-tests)/$(pkg-tests).asd $(clc-systems)/$(clc-tests).$(pkg-tests)asd
+
+       rm -rf doc/html
+       (cd doc; tar xzf html.tar.gz; cd ..)
+       dh_install doc/html $(doc-dir)
+       rm -rf doc/html
        cp doc/uffi.pdf doc/cl-uffi.pdf
-       rm -f doc/cl-uffi.pdf.gz
-       gzip doc/cl-uffi.pdf
-       $(INSTALL) $(INSTALLFLAGS) doc/cl-uffi.pdf.gz $(DOCDIR)
-       rm -f doc/cl-uffi.pdf.gz
+       gzip -9 doc/cl-uffi.pdf
+       dh_install doc/cl-uffi.pdf.gz $(doc-dir)
 
 # Build architecture-independent files here.
 binary-indep: build install
@@ -82,7 +75,7 @@ binary-arch: build install
        dh_testroot
 #      dh_installdebconf       
        dh_installdocs
-       dh_installexamples examples/*.cl
+       dh_installexamples examples/*.lisp
 #      dh_installmenu
 #      dh_installlogrotate
 #      dh_installemacsen
@@ -97,7 +90,6 @@ binary-arch: build install
        dh_strip
        dh_compress
        dh_fixperms
-       dh_link $(clc-source) $(SOURCEDIR)
 #      dh_makeshlibs
        dh_installdeb
 #      dh_perl