r2280: *** empty log message ***
[uffi.git] / debian / rules
index 0fc5ec7098dfa2d822e638adea86eb471d7a0a1e..b87d073922f94da3d03e6982229dcdff7ac4c6d2 100755 (executable)
@@ -1,25 +1,14 @@
 #!/usr/bin/make -f
-# Sample debian/rules that uses debhelper.
-# GNU copyright 1997 to 1999 by Joey Hess.
 
-# Uncomment this to turn on verbose mode.
-# export DH_VERBOSE=1
-
-# This is the debhelper compatibility version to use.
 export DH_COMPAT=4
 
 pkg    := uffi
 debpkg  := cl-uffi
 
-INSTALL        := install
-INSTALLFLAGS   := -g root -o root -m 0644
-
-UPSTREAM_VER   := $(shell sed -n -e "s/${debpkg} (\(.*\)-[0-9.]).*/\1/p" < debian/changelog |head -1)
 
-pkg-ver                := $(debpkg)-$(UPSTREAM_VER)
 clc-source     := usr/share/common-lisp/source
 clc-systems    := usr/share/common-lisp/systems
-clc-uffi       := $(clc-source)/$(pkg)-$(UPSTREAM_VER)
+clc-uffi       := $(clc-source)/$(pkg)
 
 doc-dir                := usr/share/doc/${debpkg}
 lispfiles      := $(clc-uffi)
@@ -61,7 +50,8 @@ install: build
        dh_installdirs -p $(debpkg) $(doc-dir) $(lispfiles)/mcl 
 
        # Add here commands to install the package into debian/uffi.
-       dh_install "src/*.cl" "*.system" $(lispfiles)
+       dh_install "uffi.system" $(clc-systems)
+       dh_install "src/*.cl" $(lispfiles)
        dh_install "src/mcl/*.cl" $(lispfiles)/mcl
 
        rm -rf doc/html