r2280: *** empty log message ***
[uffi.git] / debian / rules
index b9e77184bc2703317e0c9deb3f17c055d8350b1f..b87d073922f94da3d03e6982229dcdff7ac4c6d2 100755 (executable)
@@ -1,24 +1,17 @@
 #!/usr/bin/make -f
-# Sample debian/rules that uses debhelper.
-# GNU copyright 1997 to 1999 by Joey Hess.
 
-# Uncomment this to turn on verbose mode.
-# export DH_VERBOSE=1
-
-# This is the debhelper compatibility version to use.
-export DH_COMPAT=3
+export DH_COMPAT=4
 
 pkg    := uffi
 debpkg  := cl-uffi
-prefix := debian/$(debpkg)
 
-INSTALL        := install
-INSTALLFLAGS   := -g root -o root -m 0644
-INSTALLDIRFLAGS        := -d -g root -o root -m 0755
 
-SOURCEDIR      := $(prefix)/usr/share/common-lisp/source
-REPOSITORYDIR  := $(prefix)/usr/share/common-lisp/repositories/${pkg}
-DOCDIR         := $(prefix)/usr/share/doc/${debpkg}
+clc-source     := usr/share/common-lisp/source
+clc-systems    := usr/share/common-lisp/systems
+clc-uffi       := $(clc-source)/$(pkg)
+
+doc-dir                := usr/share/doc/${debpkg}
+lispfiles      := $(clc-uffi)
 
 
 configure: configure-stamp
@@ -35,7 +28,6 @@ build-stamp: configure-stamp
        dh_testdir
 
        # Add here commands to compile the package.
-       # $(MAKE) doc
 
        touch build-stamp
 
@@ -54,23 +46,26 @@ install: build
        dh_testdir
        dh_testroot
        dh_clean -k
-       dh_installdirs
+       dh_installdirs --all $(clc-systems) $(clc-source) 
+       dh_installdirs -p $(debpkg) $(doc-dir) $(lispfiles)/mcl 
 
        # Add here commands to install the package into debian/uffi.
-       $(INSTALL) $(INSTALLFLAGS) $(shell echo src/*.cl *.system) $(REPOSITORYDIR)
-       $(INSTALL) $(INSTALLFLAGS) $(shell echo src/mcl/*.cl) $(REPOSITORYDIR)/mcl
-       $(INSTALL) $(INSTALLFLAGS) doc/html/* $(DOCDIR)/html
-       cp doc/uffi.ps doc/cl-uffi.ps
-       rm -f doc/cl-uffi.ps.gz
-       gzip doc/cl-uffi.ps
-       $(INSTALL) $(INSTALLFLAGS) doc/cl-uffi.ps.gz $(DOCDIR)
-       rm -f doc/cl-uffi.ps.gz
+       dh_install "uffi.system" $(clc-systems)
+       dh_install "src/*.cl" $(lispfiles)
+       dh_install "src/mcl/*.cl" $(lispfiles)/mcl
+
+       rm -rf doc/html
+       (cd doc; tar xzf html.tar.gz; cd ..)
+       dh_install doc/html $(doc-dir)
+       rm -rf doc/html
+       cp doc/uffi.pdf doc/cl-uffi.pdf
+       gzip -9 doc/cl-uffi.pdf
+       dh_install doc/cl-uffi.pdf.gz $(doc-dir)
 
 # Build architecture-independent files here.
 binary-indep: build install
 
 
-
 # Build architecture-dependent files here.
 binary-arch: build install
        dh_testdir
@@ -89,14 +84,14 @@ binary-arch: build install
 #      dh_installinfo
 #      dh_undocumented
        dh_installchangelogs ChangeLog
-       dh_link
        dh_strip
        dh_compress
        dh_fixperms
+       dh_link -p $(debpkg) $(clc-uffi) $(clc-source)/$(pkg)
 #      dh_makeshlibs
        dh_installdeb
 #      dh_perl
-#      dh_shlibdeps
+       dh_shlibdeps
        dh_gencontrol
        dh_md5sums
        dh_builddeb