r2152: *** empty log message ***
[uffi.git] / debian / rules
index 84910cc08a2b479b68b5251bdf1656ff536943c8..ce07491aee7275d1a2a51fe4710e7e91d6e3232c 100755 (executable)
@@ -3,22 +3,28 @@
 # GNU copyright 1997 to 1999 by Joey Hess.
 
 # Uncomment this to turn on verbose mode.
-export DH_VERBOSE=1
+export DH_VERBOSE=1
 
 # This is the debhelper compatibility version to use.
-export DH_COMPAT=3
+export DH_COMPAT=4
 
-pkg    := cl-uffi
-prefix := debian/$(pkg)
+pkg    := uffi
+debpkg  := cl-uffi
+prefix := debian/$(debpkg)
 
 INSTALL        := install
 INSTALLFLAGS   := -g root -o root -m 0644
 INSTALLDIRFLAGS        := -d -g root -o root -m 0755
 
-SOURCEDIR      := $(prefix)/usr/share/common-lisp/source
-REPOSITORYDIR  := $(prefix)/usr/share/common-lisp/repositories/uffi
-SYSDIR         := $(prefix)/usr/share/common-lisp/systems
-DOCDIR         := $(prefix)/usr/share/doc/cl-uffi
+UPSTREAM_VER   := $(shell sed -n -e "s/${debpkg} (\(.*\)-[0-9.]).*/\1/p" < debian/changelog |head -1)
+
+pkg-ver                := $(debpkg)-$(UPSTREAM_VER)
+clc-source     := usr/share/common-lisp/source
+clc-systems    := usr/share/common-lisp/systems
+clc-uffi       := $(clc-source)/$(pkg)-$(UPSTREAM_VER)
+
+srcdir         := $(prefix)/$(clc-uffi)
+DOCDIR         := $(prefix)/usr/share/doc/${debpkg}
 
 
 configure: configure-stamp
@@ -35,8 +41,8 @@ build-stamp: configure-stamp
        dh_testdir
 
        # Add here commands to compile the package.
-       $(MAKE) doc
-       #/usr/bin/docbook-to-man debian/uffi.sgml > uffi.1
+       # Make doc isn't necessary because the docs are in the upstream version
+       # $(MAKE) doc
 
        touch build-stamp
 
@@ -47,6 +53,7 @@ clean:
 
        # Add here commands to clean up after the build process.
        -$(MAKE) clean
+       rm -f debian/cl-uffi.postinst.* debian/cl-uffi.prerm.*
 
        dh_clean
 
@@ -57,23 +64,21 @@ install: build
        dh_installdirs
 
        # Add here commands to install the package into debian/uffi.
-       $(INSTALL) $(INSTALLDIRFLAGS) $(REPOSITORYDIR) $(REPOSITORYDIR)/mcl $(SYSDIR) $(DOCDIR) $(DOCDIR)/html $(SOURCEDIR)
-       $(INSTALL) $(INSTALLFLAGS) uffi.system.debian $(SYSDIR)
-       mv $(SYSDIR)/uffi.system.debian $(SYSDIR)/uffi.system
-       $(INSTALL) $(INSTALLFLAGS) $(shell echo src/*.cl) $(REPOSITORYDIR)
-       $(INSTALL) $(INSTALLFLAGS) $(shell echo src/mcl/*.cl) $(REPOSITORYDIR)/mcl
+       $(INSTALL) $(INSTALLDIRFLAGS) $(srcdir)
+       $(INSTALL) $(INSTALLDIRFLAGS) $(srcdir)/mcl
+       $(INSTALL) $(INSTALLFLAGS) $(shell echo src/*.cl *.system) $(srcdir)
+       $(INSTALL) $(INSTALLFLAGS) $(shell echo src/mcl/*.cl) $(clc-source)/mcl
        $(INSTALL) $(INSTALLFLAGS) doc/html/* $(DOCDIR)/html
-       cp doc/uffi.ps doc/cl-uffi.ps
-       rm -f doc/cl-uffi.ps.gz
-       gzip doc/cl-uffi.ps
-       $(INSTALL) $(INSTALLFLAGS) doc/cl-uffi.ps.gz $(DOCDIR)
-       rm -f doc/cl-uffi.ps.gz
+       cp doc/uffi.pdf doc/cl-uffi.pdf
+       rm -f doc/cl-uffi.pdf.gz
+       gzip doc/cl-uffi.pdf
+       $(INSTALL) $(INSTALLFLAGS) doc/cl-uffi.pdf.gz $(DOCDIR)
+       rm -f doc/cl-uffi.pdf.gz
 
 # Build architecture-independent files here.
 binary-indep: build install
 
 
-
 # Build architecture-dependent files here.
 binary-arch: build install
        dh_testdir
@@ -92,14 +97,14 @@ binary-arch: build install
 #      dh_installinfo
 #      dh_undocumented
        dh_installchangelogs ChangeLog
-       dh_link
        dh_strip
        dh_compress
        dh_fixperms
+       dh_link -p $(pkg) $(clc-uffi) $(clc-source)/$(pkg)
 #      dh_makeshlibs
        dh_installdeb
 #      dh_perl
-#      dh_shlibdeps
+       dh_shlibdeps
        dh_gencontrol
        dh_md5sums
        dh_builddeb