r5100: Auto commit for Debian build
[lml.git] / debian / rules
index 8e47dc0c7205d0ee7e0cec1154ca988b13467cb3..d163ddb24c7a22fb1604d16832131629cd845d92 100755 (executable)
@@ -17,7 +17,6 @@ configure: configure-stamp
 configure-stamp:
        dh_testdir
        # Add here commands to configure the package.
-
        touch configure-stamp
 
 
@@ -25,9 +24,7 @@ build: build-stamp
 
 build-stamp: configure-stamp 
        dh_testdir
-
        # Add here commands to compile the package.
-
        touch build-stamp
 
 clean:
@@ -42,12 +39,11 @@ install: build
        dh_testdir
        dh_testroot
        dh_clean -k
-       dh_installdirs --all $(clc-systems) $(clc-source) 
-       dh_installdirs -p $(debpkg) $(doc-dir) $(clc-lml)/mcl 
        # Add here commands to install the package into debian/lml.
-       dh_install lml.system lml.asd $(clc-systems)
-       dh_install $(shell echo *.cl) $(clc-lml)
-       dh_install docs/* $(doc-dir)
+       dh_installdirs $(clc-systems) $(clc-lml) $(doc-dir)
+       dh_install lml.asd $(shell echo *.lisp) $(clc-lml)
+       dh_install $(shell echo doc/*.html) $(doc-dir)
+       dh_link $(clc-lml)/lml.asd $(clc-systems)/lml.asd
 
 # Build architecture-independent files here.
 binary-indep: build install
@@ -59,7 +55,7 @@ binary-arch: build install
        dh_testroot
 #      dh_installdebconf       
        dh_installdocs
-#      dh_installexamples
+       dh_installexamples doc/Makefile doc/make.lisp $(shell echo doc/*.lml)
 #      dh_installmenu
 #      dh_installlogrotate
 #      dh_installemacsen