r4081: Auto commit for Debian build
[uffi.git] / debian / rules
index 723f3a8045c5ada23ef70de71db833b78472484a..f561721db3bb06d31caa9f89dcb9d43807fb5320 100755 (executable)
@@ -1,31 +1,16 @@
 #!/usr/bin/make -f
-# Sample debian/rules that uses debhelper.
-# GNU copyright 1997 to 1999 by Joey Hess.
 
-# Uncomment this to turn on verbose mode.
-# export DH_VERBOSE=1
-
-# This is the debhelper compatibility version to use.
 export DH_COMPAT=4
 
 pkg    := uffi
 debpkg  := cl-uffi
-prefix := debian/$(debpkg)
-
-INSTALL        := install
-INSTALLFLAGS   := -g root -o root -m 0644
-INSTALLDIRFLAGS        := -d -g root -o root -m 0755
 
-UPSTREAM_VER   := $(shell sed -n -e "s/${debpkg} (\(.*\)-[0-9.]).*/\1/p" < debian/changelog |head -1)
 
-pkg-ver                := $(debpkg)-$(UPSTREAM_VER)
 clc-source     := usr/share/common-lisp/source
 clc-systems    := usr/share/common-lisp/systems
-clc-uffi       := $(clc-source)/$(pkg)-$(UPSTREAM_VER)
+clc-uffi       := $(clc-source)/$(pkg)
 
-pkg-doc                := usr/share/doc/${debpkg}
-lispfiles      := $(prefix)/$(clc-uffi)
-docfiles       := $(prefix)/$(pkg-doc)
+doc-dir                := usr/share/doc/$(debpkg)
 
 
 configure: configure-stamp
@@ -42,8 +27,6 @@ build-stamp: configure-stamp
        dh_testdir
 
        # Add here commands to compile the package.
-       # Make doc isn't necessary because the docs are in the upstream version
-       # $(MAKE) doc
 
        touch build-stamp
 
@@ -63,21 +46,20 @@ install: build
        dh_testroot
        dh_clean -k
        dh_installdirs --all $(clc-systems) $(clc-source) 
-       dh_installdirs -p $(debpkg) $(pkg-doc)/html $(clc-uffi)/mcl 
+       dh_installdirs -p $(debpkg) $(doc-dir) $(clc-uffi)/src
 
        # Add here commands to install the package into debian/uffi.
-       $(INSTALL) $(INSTALLFLAGS) $(shell echo src/*.cl *.system) $(lispfiles)
-       $(INSTALL) $(INSTALLFLAGS) $(shell echo src/mcl/*.cl) $(lispfiles)/mcl
+       dh_install uffi.asd $(clc-uffi)
+       dh_install "src/*.lisp" $(clc-uffi)/src
+       dh_link $(clc-uffi)/uffi.asd $(clc-systems)/uffi.asd
 
        rm -rf doc/html
        (cd doc; tar xzf html.tar.gz; cd ..)
-       $(INSTALL) $(INSTALLFLAGS) doc/html/* $(docfiles)/html
+       dh_install doc/html $(doc-dir)
        rm -rf doc/html
        cp doc/uffi.pdf doc/cl-uffi.pdf
-       rm -f doc/cl-uffi.pdf.gz
-       gzip doc/cl-uffi.pdf
-       $(INSTALL) $(INSTALLFLAGS) doc/cl-uffi.pdf.gz $(docfiles)
-       rm -f doc/cl-uffi.pdf.gz
+       gzip -9 doc/cl-uffi.pdf
+       dh_install doc/cl-uffi.pdf.gz $(doc-dir)
 
 # Build architecture-independent files here.
 binary-indep: build install
@@ -89,7 +71,7 @@ binary-arch: build install
        dh_testroot
 #      dh_installdebconf       
        dh_installdocs
-       dh_installexamples examples/*.cl
+       dh_installexamples examples/*.lisp
 #      dh_installmenu
 #      dh_installlogrotate
 #      dh_installemacsen
@@ -104,7 +86,6 @@ binary-arch: build install
        dh_strip
        dh_compress
        dh_fixperms
-       dh_link -p $(debpkg) $(clc-uffi) $(clc-source)/$(pkg)
 #      dh_makeshlibs
        dh_installdeb
 #      dh_perl