add vcs-browser field to control
[cl-base64.git] / debian / rules
index 54ac3fe3f812bdd64907959cd37c27a44bb9f7c3..dba82141a361e898b2c262107c58369dec5f4362 100755 (executable)
@@ -1,69 +1,44 @@
 #!/usr/bin/make -f
 
-export DH_COMPAT=4
-
-pkg    := base64
-debpkg  := cl-base64
-
+pkg            := cl-base64
+debpkg         := cl-base64
 
 clc-source     := usr/share/common-lisp/source
 clc-systems    := usr/share/common-lisp/systems
-clc-base64     := $(clc-source)/$(pkg)
-
+clc-files      := $(clc-source)/$(pkg)
 doc-dir                := usr/share/doc/$(debpkg)
 
-
-configure: configure-stamp
-configure-stamp:
-       dh_testdir
-       # Add here commands to configure the package.
-
-       touch configure-stamp
-
-
-build: build-stamp
-
-build-stamp: configure-stamp 
-       dh_testdir
-       # Add here commands to compile the package.
-       touch build-stamp
+build:
 
 clean:
        dh_testdir
        dh_testroot
-       rm -f build-stamp configure-stamp
-       # Add here commands to clean up after the build process.
-       rm -f debian/cl-base64.postinst.* debian/cl-base64.prerm.*
        dh_clean
 
 install: build
        dh_testdir
        dh_testroot
-       dh_clean -k
-       # Add here commands to install the package into debian/base64.
-       dh_installdirs $(clc-systems) $(clc-base64)
-       dh_install base64.asd $(shell echo *.lisp) $(clc-base64)
-       dh_link $(clc-base64)/base64.asd $(clc-systems)/base64.asd
-
-# Build architecture-independent files here.
-binary-indep: build install
-
+       dh_prep
+       dh_installdirs
+       dh_install $(pkg).asd $(clc-files)
+       dh_install *.lisp $(clc-files)
 
-# Build architecture-dependent files here.
-binary-arch: build install
+binary-indep: install
        dh_testdir
        dh_testroot
-       dh_installdocs
        dh_installchangelogs
-       dh_strip
+       dh_installdocs
+       dh_lisp
        dh_compress
        dh_fixperms
        dh_installdeb
-       dh_shlibdeps
        dh_gencontrol
        dh_md5sums
        dh_builddeb
 
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install configure
+binary-arch:
+
+binary: binary-indep
+
 
+.PHONY: build clean binary-indep binary-arch binary install