Changes to conform to new debian policies debian-3.3.2-2 v3.3.2
authorKevin Rosenberg <kevin@rosenberg.net>
Sun, 2 Aug 2009 02:00:38 +0000 (20:00 -0600)
committerKevin Rosenberg <kevin@rosenberg.net>
Sun, 2 Aug 2009 02:00:38 +0000 (20:00 -0600)
cl-base64.asd
debian/changelog
debian/compat
debian/control
debian/postinst
debian/prerm
debian/rules
debian/watch [new file with mode: 0644]

index 8c02f90fb6f2f1b8291cdc47052e6953e7764a52..252389d873d969f88e7a190dd239418ed995df6d 100644 (file)
@@ -22,7 +22,6 @@
   :maintainer "Kevin M. Rosenberg <kmr@debian.org>"
   :licence "BSD-style"
   :description "Base64 encoding and decoding with URI support."
-  
   :components
   ((:file "package")
    (:file "encode" :depends-on ("package"))
@@ -35,7 +34,6 @@
 
 (defsystem cl-base64-tests
     :depends-on (cl-base64 ptester kmrcl)
-  
     :components
     ((:file "tests")))
 
index 44932a0ca6f690387c71c14c2bdd87b6d7485f75..6d9d280e5181ca2e4a5ae47ffb926e8924fbf462 100644 (file)
@@ -1,3 +1,15 @@
+cl-base64 (3.3.2-2) unstable; urgency=low
+
+  * New upstream
+  * Convert to debhelper version 7
+  * debian/watch: New file
+  * debian/control: Change section to new lisp section. Add Vcs-Git
+  and Homepage fields.
+  * debian/rules: Change to just architecture independent rules and DH7
+  * debian/{prerm,postinst}: Remove paths from binary function
+
+ -- Kevin M. Rosenberg <kmr@debian.org>  Sat, 01 Aug 2009 19:41:27 -0600
+
 cl-base64 (3.3.2-1) unstable; urgency=low
 
   * Depend on kmrcl only for test package
index b8626c4cff2849624fb67f87cd0ad72b163671ad..7f8f011eb73d6043d2e6db9d2c101195ae2801f2 100644 (file)
@@ -1 +1 @@
-4
+7
index 664fe3c0c6257163434033fb116ec79d97f513ec..66f541c317a24d4138f740ea9a3675fd6be22959 100644 (file)
@@ -1,13 +1,15 @@
 Source: cl-base64
-Section: devel
+Section: lisp
 Priority: optional
 Maintainer: Kevin M. Rosenberg <kmr@debian.org>
-Build-Depends: debhelper (>= 4.0.0)
-Standards-Version: 3.7.2.1
+Build-Depends: debhelper (>= 7.0.0)
+Standards-Version: 3.8.2.0
+Vcs-Git: git://git.b9.com/cl-base64.git
+Homepage: http://files.b9.com/cl-base64/
 
 Package: cl-base64
 Architecture: all
-Depends: ${shlibs:Depends}, common-lisp-controller (>= 3.47), cl-kmrcl
+Depends: common-lisp-controller (>= 3.47), cl-kmrcl
 Description: Common Lisp package to encode and decode base64 with URI support
  This package provides highly optimized base64 encoding and decoding.
  Besides conversion to and from strings, integer conversions are supported.
index 9cbf5edff2429aebbf61206b88a7d10002666cab..40ae7d75b092a32e0d97f0064d3448cbbae13117 100755 (executable)
@@ -3,27 +3,9 @@ set -e
 
 LISP_PKG=cl-base64
 
-# summary of how this script can be called:
-#        * <postinst> `configure' <most-recently-configured-version>
-#        * <old-postinst> `abort-upgrade' <new version>
-#        * <conflictor's-postinst> `abort-remove' `in-favour' <package>
-#          <new-version>
-#        * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
-#          <failed-install-package> <version> `removing'
-#          <conflicting-package> <version>
-# for details, see http://www.debian.org/doc/debian-policy/ or
-# the debian-policy package
-#
-# quoting from the policy:
-#     Any necessary prompting should almost always be confined to the
-#     post-installation script, and should be protected with a conditional
-#     so that unnecessary prompting doesn't happen if a package's
-#     installation fails and the `postinst' is called with `abort-upgrade',
-#     `abort-remove' or `abort-deconfigure'.
-
 case "$1" in
     configure)
-       /usr/sbin/register-common-lisp-source ${LISP_PKG}
+       register-common-lisp-source ${LISP_PKG}
        ;;
     abort-upgrade|abort-remove|abort-deconfigure)
        ;;
@@ -33,9 +15,6 @@ case "$1" in
        ;;
 esac
 
-# dh_installdeb will replace this with shell code automatically
-# generated by other debhelper scripts.
-
 #DEBHELPER#
 
 exit 0
index 5f2f5ac3ce2476df3e66af2763cbc1e1e36b2294..698ab1a2743438377b55476d95c8ed963ebc6887 100755 (executable)
@@ -3,21 +3,9 @@ set -e
 
 LISP_PKG=cl-base64
 
-# summary of how this script can be called:
-#        * <prerm> `remove'
-#        * <old-prerm> `upgrade' <new-version>
-#        * <new-prerm> `failed-upgrade' <old-version>
-#        * <conflictor's-prerm> `remove' `in-favour' <package> <new-version>
-#        * <deconfigured's-prerm> `deconfigure' `in-favour'
-#          <package-being-installed> <version> `removing'
-#          <conflicting-package> <version>
-# for details, see http://www.debian.org/doc/debian-policy/ or
-# the debian-policy package
-
-
 case "$1" in
     remove|upgrade|deconfigure)
-       /usr/sbin/unregister-common-lisp-source ${LISP_PKG}
+       unregister-common-lisp-source ${LISP_PKG}
         ;;
     failed-upgrade)
         ;;
index 7c3fc59febffc45f4f6d4247a7131e6bbe7a5b8e..b78ec061a6e96f00791513d11c96254d97a426c6 100755 (executable)
@@ -3,19 +3,15 @@
 pkg    := cl-base64
 debpkg  := cl-base64
 
-
 clc-source     := usr/share/common-lisp/source
 clc-systems    := usr/share/common-lisp/systems
 clc-base64     := $(clc-source)/$(pkg)
 
 doc-dir                := usr/share/doc/$(debpkg)
 
-
 configure: configure-stamp
 configure-stamp:
        dh_testdir
-       # Add here commands to configure the package.
-
        touch configure-stamp
 
 
@@ -23,45 +19,39 @@ build: build-stamp
 
 build-stamp: configure-stamp 
        dh_testdir
-       # Add here commands to compile the package.
        touch build-stamp
 
 clean:
        dh_testdir
        dh_testroot
        rm -f build-stamp configure-stamp
-       # Add here commands to clean up after the build process.
        rm -f debian/cl-base64.postinst.* debian/cl-base64.prerm.*
        dh_clean
 
 install: build
        dh_testdir
        dh_testroot
-       dh_clean -k
-       # Add here commands to install the package into debian/cl-base64.
+       dh_prep
        dh_installdirs $(clc-systems) $(clc-base64)
        dh_install *.asd $(shell echo *.lisp) $(clc-base64)
        dh_link $(clc-base64)/cl-base64.asd $(clc-systems)/cl-base64.asd
 
 # Build architecture-independent files here.
 binary-indep: build install
+       dh_testdir -i
+       dh_testroot -i
+       dh_installdocs -i
+       dh_installchangelogs -i
+       dh_strip -i
+       dh_compress -i
+       dh_fixperms -i
+       dh_installdeb -i
+       dh_gencontrol -i
+       dh_md5sums -i
+       dh_builddeb -i
 
-
-# Build architecture-dependent files here.
 binary-arch: build install
-       dh_testdir
-       dh_testroot
-       dh_installdocs
-       dh_installchangelogs
-       dh_strip
-       dh_compress
-       dh_fixperms
-       dh_installdeb
-       dh_shlibdeps
-       dh_gencontrol
-       dh_md5sums
-       dh_builddeb
 
 binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install configure
+.PHONY: build clean binary-indep binary install configure
 
diff --git a/debian/watch b/debian/watch
new file mode 100644 (file)
index 0000000..7d41af4
--- /dev/null
@@ -0,0 +1,2 @@
+version=3
+http://files.b9.com/cl-base64/cl-base64-(\d+.*)\.tar\.gz