r3229: split arch & indep pkgs
[clsql.git] / debian / rules
index 222f0ff12d0c5c0b77c777aad8cba209305b8378..41d3289225ceb98f15f0cd4809c1005915d981d7 100755 (executable)
@@ -1,11 +1,5 @@
 #!/usr/bin/make -f
-# Sample debian/rules that uses debhelper.
-# GNU copyright 1997 to 1999 by Joey Hess.
 
-# Uncomment this to turn on verbose mode.
-export DH_VERBOSE=1
-
-# This is the debhelper compatibility version to use.
 export DH_COMPAT=4
 
 plain-pkg      := clsql
@@ -57,7 +51,6 @@ lispdir-pg-socket := $(clc-pg-socket)/db-postgresql-socket
 clc-aodbc      := $(clc-source)/clsql-aodbc
 lispdir-aodbc  := $(clc-aodbc)/db-aodbc
 
-
 configure: configure-stamp
 configure-stamp:
        dh_testdir
@@ -65,26 +58,40 @@ configure-stamp:
        touch configure-stamp
 
 
-build: build-stamp
-
-build-stamp: configure-stamp 
+build-arch: configure-stamp build-arch-stamp
+build-arch-stamp:
        dh_testdir
-       # Compile helper libraries
+       # Add here commands to compile the package.
        $(MAKE)
-       touch build-stamp
+       touch build-arch-stamp
+
+build-indep: configure-stamp  build-indep-stamp
+build-indep-stamp:
+       dh_testdir
+       # Add here command to compile/build the arch indep package.
+       # It's ok not to do anything here, if you don't need to build
+       #  anything for this package.
+       #/usr/bin/docbook-to-man debian/#PACKAGE#.sgml > #PACKAGE#.1
+       touch build-indep-stamp
+
+build: build-arch build-indep
 
 clean:
        dh_testdir
        dh_testroot
-       rm -f build-stamp configure-stamp
+       rm -f build-arch-stamp build-indep-stamp configure-stamp
        # Add here commands to clean up after the build process.
-       $(MAKE) clean
+       -$(MAKE) clean
+       find . -type f -and -name \*~ -or -name .\*~ -exec rm -f {} \;
        dh_clean
 
+install: DH_OPTIONS=
 install: build
        dh_testdir
        dh_testroot
        dh_clean -k
+       dh_installdirs
+       # Add here commands to install the package into debian/uffi.
        dh_installdirs --all  $(clc-systems) $(clc-source)
        dh_installdirs -p $(pkg) $(lispdir-sql)
        dh_installdirs -p $(pkg-base) $(lispdir-base)
@@ -155,28 +162,64 @@ install: build
 
 
 # Build architecture-independent files here.
+# Pass -i to all debhelper commands in this target to reduce clutter.
 binary-indep: build install
-
-
+       dh_testdir -i
+       dh_testroot -i
+#      dh_installdebconf -i
+       dh_installdocs -i
+       dh_installexamples -i
+       dh_installmenu -i
+#      dh_installlogrotate -i
+#      dh_installemacsen -i
+#      dh_installpam -i
+#      dh_installmime -i
+#      dh_installinit -i
+       dh_installcron -i
+#      dh_installman -i
+       dh_installinfo -i
+#      dh_undocumented -i
+       dh_installchangelogs ChangeLog -i
+       dh_link -i
+       dh_compress -i
+       dh_fixperms -i
+       dh_installdeb -i
+#      dh_perl -i
+       dh_gencontrol -i
+       dh_md5sums -i
+       dh_builddeb -i
 
 # Build architecture-dependent files here.
 binary-arch: build install
-       dh_testdir
-       dh_testroot
-#      dh_installdebconf       
-       dh_installdocs
-#      dh_installexamples 
-       dh_installchangelogs ChangeLog
-       dh_strip
-       dh_compress
-       dh_fixperms
-#      dh_makeshlibs
-       dh_installdeb
-#      dh_perl
-       dh_shlibdeps
-       dh_gencontrol
-       dh_md5sums
-       dh_builddeb
+       dh_testdir -a
+       dh_testroot -a
+#      dh_installdebconf -a
+       dh_installdocs -a
+       dh_installexamples -a
+       dh_installmenu -a
+#      dh_installlogrotate -a
+#      dh_installemacsen -a
+#      dh_installpam -a
+#      dh_installmime -a
+#      dh_installinit -a
+       dh_installcron -a
+#      dh_installman -a
+       dh_installinfo -a
+#      dh_undocumented -a
+       dh_installchangelogs ChangeLog -a
+       dh_strip -a
+       dh_link -a
+       dh_compress -a
+       dh_fixperms -a
+#      dh_makeshlibs -a
+       dh_installdeb -a
+#      dh_perl -a
+       dh_shlibdeps -a
+       dh_gencontrol -a
+       dh_md5sums -a
+       dh_builddeb -a
 
 binary: binary-indep binary-arch
+
 .PHONY: build clean binary-indep binary-arch binary install configure
+