Version 6.5.0 Release
[clsql.git] / debian / rules
index 4765cc585f9795d1220454af1e2d297c4f009ed6..74d450051afb07ddc0116befc80c58b0294b4efa 100755 (executable)
@@ -19,7 +19,7 @@ all-pkgs      := $(pkg) $(pkg-uffi) $(pkg-mysql) $(pkg-pg) $(pkg-pg-socket) $(pkg-aod
 UPSTREAM_VER   := $(shell sed -n -e "s/${pkg} (\(.*\)-[0-9A-Za-z\.]).*/\1/p" < debian/changelog |head -1)
 
 ## Lisp sources
-srcs           := $(wildcard sql/*.lisp) clsql.asd
+srcs-sql       := $(wildcard sql/*.lisp)
 srcs-uffi      := $(wildcard uffi/*.lisp) $(wildcard uffi/*.c)
 srcs-uffi-so   = $(wildcard uffi/*.so)
 srcs-mysql     := $(wildcard db-mysql/*.lisp) $(wildcard db-mysql/*.c)
@@ -92,7 +92,7 @@ install: build
        dh_prep
        dh_installdirs
 
-       dh_installdirs --all  $(clc-systems) $(clc-source)
+       dh_installdirs --all $(clc-source)
        dh_installdirs -p $(pkg) $(lispdir-sql) etc
        dh_installdirs -p $(pkg-uffi) $(lispdir-uffi) $(sodir-uffi)
        dh_installdirs -p $(pkg-pg) $(lispdir-pg)
@@ -106,7 +106,7 @@ install: build
        dh_installdirs -p $(pkg-tests) $(lispdir-tests)
 
        # Main package
-       dh_install -p $(pkg) $(srcs) $(lispdir-sql)
+       dh_install -p $(pkg) $(srcs-sql) $(lispdir-sql)
        dh_install -p $(pkg) clsql.asd $(clc-clsql)
        dh_install -p $(pkg) debian/clsql-init.lisp etc