r10612: 05 Jul 2005 Kevin Rosenberg <kevin@rosenberg.net>
[clsql.git] / debian / rules
index 22a32dc00b67254e083a9a9c508958176ecf2c77..90505795ca7c90ffb88234e6bce81ca515e83db0 100755 (executable)
@@ -10,9 +10,10 @@ pkg-pg-socket        := cl-sql-postgresql-socket
 pkg-aodbc      := cl-sql-aodbc
 pkg-odbc       := cl-sql-odbc
 pkg-sqlite     := cl-sql-sqlite
+pkg-sqlite3    := cl-sql-sqlite3
 pkg-oracle     := cl-sql-oracle
 pkg-tests      := cl-sql-tests
-all-pkgs       := $(pkg) $(pkg-uffi) $(pkg-mysql) $(pkg-pg) $(pkg-pg-socket) $(pkg-aodbc) $(pkg-odbc) $(pkg-sqlite) $(pkg-tests)
+all-pkgs       := $(pkg) $(pkg-uffi) $(pkg-mysql) $(pkg-pg) $(pkg-pg-socket) $(pkg-aodbc) $(pkg-odbc) $(pkg-sqlite) $(pkg-sqlite3) $(pkg-tests)
 
 
 UPSTREAM_VER   := $(shell sed -n -e "s/${pkg} (\(.*\)-[0-9A-Za-z\.]).*/\1/p" < debian/changelog |head -1)
@@ -28,6 +29,7 @@ srcs-pg-socket        := $(wildcard db-postgresql-socket/*.lisp)
 srcs-aodbc     := $(wildcard db-aodbc/*.lisp)
 srcs-odbc      := $(wildcard db-odbc/*.lisp)
 srcs-sqlite    := $(wildcard db-sqlite/*.lisp)
+srcs-sqlite3   := $(wildcard db-sqlite3/*.lisp)
 srcs-oracle    := $(wildcard db-oracle/*.lisp)
 srcs-tests     := $(wildcard tests/*.lisp)
 
@@ -56,32 +58,28 @@ clc-odbc    := $(clc-source)/clsql-odbc
 lispdir-odbc   := $(clc-odbc)/db-odbc
 clc-sqlite     := $(clc-source)/clsql-sqlite
 lispdir-sqlite := $(clc-sqlite)/db-sqlite
+clc-sqlite3    := $(clc-source)/clsql-sqlite3
+lispdir-sqlite3        := $(clc-sqlite3)/db-sqlite3
 clc-oracle     := $(clc-source)/clsql-oracle
-lispdir-oracle := $(clc-sqlite)/db-oracle
+lispdir-oracle := $(clc-oracle)/db-oracle
 clc-tests      := $(clc-source)/clsql-tests
 lispdir-tests  := $(clc-tests)/tests
 
 configure: configure-stamp
 configure-stamp:
        dh_testdir
-       # Add here commands to configure the package.
        touch configure-stamp
 
 
 build-arch: configure-stamp build-arch-stamp
 build-arch-stamp:
        dh_testdir
-       # Add here commands to compile the package.
        $(MAKE)
        touch build-arch-stamp
 
 build-indep: configure-stamp  build-indep-stamp
 build-indep-stamp:
        dh_testdir
-       # Add here command to compile/build the arch indep package.
-       # It's ok not to do anything here, if you don't need to build
-       #  anything for this package.
-       #/usr/bin/docbook-to-man debian/#PACKAGE#.sgml > #PACKAGE#.1
        touch build-indep-stamp
 
 build: build-arch build-indep
@@ -90,7 +88,6 @@ clean:
        dh_testdir
        dh_testroot
        rm -f build-arch-stamp build-indep-stamp configure-stamp
-       # Add here commands to clean up after the build process.
        -$(MAKE) clean
        find . -type f -and -name \*~ -or -name .\*~ -exec rm -f {} \;
        dh_clean
@@ -102,9 +99,8 @@ install: build
        dh_clean -k
        dh_installdirs
 
-       # Add here commands to install the package into debian/uffi.
        dh_installdirs --all  $(clc-systems) $(clc-source)
-       dh_installdirs -p $(pkg) $(lispdir-sql)
+       dh_installdirs -p $(pkg) $(lispdir-sql) etc
        dh_installdirs -p $(pkg-uffi) $(lispdir-uffi) $(sodir-uffi)
        dh_installdirs -p $(pkg-pg) $(lispdir-pg)
        dh_installdirs -p $(pkg-pg-socket) $(lispdir-pg-socket)
@@ -112,12 +108,14 @@ install: build
        dh_installdirs -p $(pkg-aodbc) $(lispdir-aodbc)
        dh_installdirs -p $(pkg-odbc) $(lispdir-odbc)
        dh_installdirs -p $(pkg-sqlite) $(lispdir-sqlite)
+       dh_installdirs -p $(pkg-sqlite3) $(lispdir-sqlite3)
        dh_installdirs -p $(pkg-oracle) $(lispdir-oracle)
        dh_installdirs -p $(pkg-tests) $(lispdir-tests)
 
        # Main package
        dh_install -p $(pkg) $(srcs) $(lispdir-sql)
        dh_install -p $(pkg) clsql.asd $(clc-clsql)
+       dh_install -p $(pkg) debian/clsql-init.lisp etc
 
        # UFFI
        dh_install -p $(pkg-uffi) $(srcs-uffi) $(lispdir-uffi)
@@ -138,6 +136,8 @@ install: build
        dh_install -p $(pkg-odbc) clsql-odbc.asd $(clc-odbc)
        dh_install -p $(pkg-sqlite) $(srcs-sqlite) $(lispdir-sqlite)
        dh_install -p $(pkg-sqlite) clsql-sqlite.asd $(clc-sqlite)
+       dh_install -p $(pkg-sqlite3) $(srcs-sqlite3) $(lispdir-sqlite3)
+       dh_install -p $(pkg-sqlite3) clsql-sqlite3.asd $(clc-sqlite3)
        dh_install -p $(pkg-oracle) $(srcs-oracle) $(lispdir-oracle)
        dh_install -p $(pkg-oracle) clsql-oracle.asd $(clc-oracle)
 
@@ -153,6 +153,7 @@ install: build
        dh_link -p $(pkg-aodbc) $(clc-aodbc)/clsql-aodbc.asd $(clc-systems)/clsql-aodbc.asd
        dh_link -p $(pkg-odbc) $(clc-odbc)/clsql-odbc.asd $(clc-systems)/clsql-odbc.asd
        dh_link -p $(pkg-sqlite) $(clc-sqlite)/clsql-sqlite.asd $(clc-systems)/clsql-sqlite.asd
+       dh_link -p $(pkg-sqlite3) $(clc-sqlite3)/clsql-sqlite3.asd $(clc-systems)/clsql-sqlite3.asd
        dh_link -p $(pkg-oracle) $(clc-oracle)/clsql-oracle.asd $(clc-systems)/clsql-oracle.asd
        dh_link -p $(pkg-tests) $(clc-tests)/clsql-tests.asd $(clc-systems)/clsql-tests.asd
 
@@ -179,8 +180,6 @@ install: build
        done
 
 
-# Build architecture-independent files here.
-# Pass -i to all debhelper commands in this target to reduce clutter.
 binary-indep: build install
        dh_testdir -i
        dh_testroot -i
@@ -201,6 +200,7 @@ binary-indep: build install
        dh_link -i
        dh_compress -i
        dh_fixperms -i
+#      dh_makeshlibs -i
        dh_installdeb -i
 #      dh_perl -i
        dh_gencontrol -i
@@ -229,7 +229,7 @@ binary-arch: build install
        dh_link -a
        dh_compress -a
        dh_fixperms -a
-#      dh_makeshlibs -a
+#      dh_makeslhibs -a
        dh_installdeb -a
 #      dh_perl -a
        dh_shlibdeps -a
@@ -240,4 +240,3 @@ binary-arch: build install
 binary: binary-indep binary-arch
 
 .PHONY: build clean binary-indep binary-arch binary install configure
-