r10612: 05 Jul 2005 Kevin Rosenberg <kevin@rosenberg.net>
[clsql.git] / debian / rules
index 49f81f78974ed9f9812cb6840d2c5ba18f780068..90505795ca7c90ffb88234e6bce81ca515e83db0 100755 (executable)
@@ -68,24 +68,18 @@ lispdir-tests       := $(clc-tests)/tests
 configure: configure-stamp
 configure-stamp:
        dh_testdir
-       # Add here commands to configure the package.
        touch configure-stamp
 
 
 build-arch: configure-stamp build-arch-stamp
 build-arch-stamp:
        dh_testdir
-       # Add here commands to compile the package.
        $(MAKE)
        touch build-arch-stamp
 
 build-indep: configure-stamp  build-indep-stamp
 build-indep-stamp:
        dh_testdir
-       # Add here command to compile/build the arch indep package.
-       # It's ok not to do anything here, if you don't need to build
-       #  anything for this package.
-       #/usr/bin/docbook-to-man debian/#PACKAGE#.sgml > #PACKAGE#.1
        touch build-indep-stamp
 
 build: build-arch build-indep
@@ -94,7 +88,6 @@ clean:
        dh_testdir
        dh_testroot
        rm -f build-arch-stamp build-indep-stamp configure-stamp
-       # Add here commands to clean up after the build process.
        -$(MAKE) clean
        find . -type f -and -name \*~ -or -name .\*~ -exec rm -f {} \;
        dh_clean
@@ -106,9 +99,8 @@ install: build
        dh_clean -k
        dh_installdirs
 
-       # Add here commands to install the package into debian/uffi.
        dh_installdirs --all  $(clc-systems) $(clc-source)
-       dh_installdirs -p $(pkg) $(lispdir-sql)
+       dh_installdirs -p $(pkg) $(lispdir-sql) etc
        dh_installdirs -p $(pkg-uffi) $(lispdir-uffi) $(sodir-uffi)
        dh_installdirs -p $(pkg-pg) $(lispdir-pg)
        dh_installdirs -p $(pkg-pg-socket) $(lispdir-pg-socket)
@@ -123,6 +115,7 @@ install: build
        # Main package
        dh_install -p $(pkg) $(srcs) $(lispdir-sql)
        dh_install -p $(pkg) clsql.asd $(clc-clsql)
+       dh_install -p $(pkg) debian/clsql-init.lisp etc
 
        # UFFI
        dh_install -p $(pkg-uffi) $(srcs-uffi) $(lispdir-uffi)
@@ -187,8 +180,6 @@ install: build
        done
 
 
-# Build architecture-independent files here.
-# Pass -i to all debhelper commands in this target to reduce clutter.
 binary-indep: build install
        dh_testdir -i
        dh_testroot -i
@@ -209,6 +200,7 @@ binary-indep: build install
        dh_link -i
        dh_compress -i
        dh_fixperms -i
+#      dh_makeshlibs -i
        dh_installdeb -i
 #      dh_perl -i
        dh_gencontrol -i
@@ -237,7 +229,7 @@ binary-arch: build install
        dh_link -a
        dh_compress -a
        dh_fixperms -a
-#      dh_makeshlibs -a
+#      dh_makeslhibs -a
        dh_installdeb -a
 #      dh_perl -a
        dh_shlibdeps -a
@@ -248,4 +240,3 @@ binary-arch: build install
 binary: binary-indep binary-arch
 
 .PHONY: build clean binary-indep binary-arch binary install configure
-