r11226: remove athlon binary
[ctsim.git] / debian / rules
index ee8a157825762bc5deffa2f72be2db97ad1f65dd..0678a20588750debc8a8bd81eea59d8c90b072c2 100755 (executable)
@@ -11,7 +11,6 @@ host_arch     := $(shell dpkg-architecture -qDEB_HOST_ARCH)
 
 pkg            := ctsim
 pkg-p4         := ctsim-pentium4
-pkg-athlon     := ctsim-athlon
 pkg-help       := ctsim-help
 pkg-doc                := ctsim-doc
 
@@ -19,13 +18,11 @@ ctsim-shared        := usr/share/ctsim
 
 prefix         := debian/$(pkg)
 prefix-p4      := debian/$(pkg-p4)
-prefix-athlon  := debian/$(pkg-athlon)
 prefix-help    := debian/$(pkg-help)
 prefix-doc     := debian/$(pkg-doc)
 
 DESTDIR                := `pwd`/$(prefix)
 DESTDIR-P4     := `pwd`/$(prefix-p4)
-DESTDIR-ATHLON := `pwd`/$(prefix-athlon)
 HELPDIR                := `pwd`/$(prefix-help)/$(ctsim-shared)
 doc-dir                := usr/share/doc/$(pkg-doc)
 pixmap-dir     := usr/share/pixmaps
@@ -90,19 +87,11 @@ ifneq (,$(findstring i386,$(host_arch)))
        ./configure --prefix=$(DESTDIR-P4)/usr --mandir=$(DESTDIR-P4)/usr/share/man --datadir=$(HELPDIR) --with-ctn --with-mcpu=pentium4
        $(MAKE) all
        ${MAKE} install
-       # Athlon
-       ${MAKE} clean
-       ./configure --prefix=$(DESTDIR-ATHLON)/usr --mandir=$(DESTDIR-ATHLON)/usr/share/man --datadir=$(HELPDIR) --with-ctn --with-mcpu=athlon
-       $(MAKE) all
-       ${MAKE} install
+
        dh_installdirs -p $(pkg-p4) $(pixmap-dir)
        dh_installdirs -p $(pkg-p4) $(desktop-dir)
-       dh_installdirs -p $(pkg-athlon) $(pixmap-dir)
-       dh_installdirs -p $(pkg-athlon) $(desktop-dir)
        dh_install -p $(pkg-p4) debian/ctsim.xpm $(pixmap-dir)
        dh_install -p $(pkg-p4) debian/ctsim.desktop $(desktop-dir)
-       dh_install -p $(pkg-athlon) debian/ctsim.xpm $(pixmap-dir)
-       dh_install -p $(pkg-athlon) debian/ctsim.desktop $(desktop-dir)
 
 endif
        # Add here commands to install the package into debian/ctsim.
@@ -118,7 +107,6 @@ endif
        gunzip docs/ctsim.pdf.gz
        chmod +x helical/*.sh tools/*.sh
 
-# Build architecture-independent files here.
 # Pass -i to all debhelper commands in this target to reduce clutter.
 binary-indep: build install
        dh_testdir -i
@@ -145,11 +133,8 @@ binary-arch: build install
        dh_installexamples -p $(pkg) tools/sample-ctsim.sh helical/sample-helical.sh
 ifneq (,$(findstring i386,$(host_arch)))
        dh_installexamples -p $(pkg-p4) tools/sample-ctsim.sh helical/sample-helical.sh
-       dh_installexamples -p $(pkg-athlon) tools/sample-ctsim.sh helical/sample-helical.sh
 endif
-
-ifeq (,$(findstring i386,$(host_arch)))
-       dh_installchangelogs -p $(pkg)ChangeLog 
+       dh_installchangelogs -p $(pkg) ChangeLog 
        dh_strip -p $(pkg)
        dh_link -p $(pkg)
        dh_compress -p $(pkg)
@@ -160,19 +145,6 @@ ifeq (,$(findstring i386,$(host_arch)))
        dh_shlibdeps -p $(pkg)
        dh_md5sums -p $(pkg)
        dh_builddeb -p $(pkg)
-else
-       dh_installchangelogs ChangeLog -a
-       dh_strip -a
-       dh_link -a
-       dh_compress -a
-       dh_fixperms -a
-       dh_installmenu -a
-       dh_installdeb -a
-       dh_gencontrol -a
-       dh_shlibdeps -a
-       dh_md5sums -a
-       dh_builddeb -a
-endif
 
 binary: binary-indep binary-arch