debian/control: Change Build-Depends to libpng-dev from libpng12-dev
[ctsim.git] / debian / rules
index 42f8109b3fd04780a0534fc7e9307054be915452..827e148cb6e5f7c82616f088b76ce561d0c03fea 100755 (executable)
@@ -28,6 +28,7 @@ desktop-dir   := usr/share/applications
 configure: configure-stamp
 configure-stamp:
        dh_testdir
+       dh_autotools-dev_updateconfig
        ./configure --prefix=$(DESTDIR)/usr --mandir=$(DESTDIR)/usr/share/man --datadir=$(HELPDIR) --with-ctn -with-x --without-lam
        touch configure-stamp
 
@@ -53,11 +54,8 @@ clean:
        if [ -f Makefile -a -f config.status ]; then $(MAKE) clean; fi
        find . -type f -and -name \*~ -or -name .\*~ -exec rm -f {} \;
        rm -f debian/ctsim.postinst.* debian/ctsim.prerm.*
-       # Ensure up-to-date versions of config.sub and config.guess
-       -test -r /usr/share/misc/config.sub && cp -f /usr/share/misc/config.sub config.sub
-       -test -r /usr/share/misc/config.guess && cp -f /usr/share/misc/config.guess config.guess
+       dh_autotools-dev_restoreconfig
        -rm -f configure-stamp build-indep-stamp build-arch-stamp
-       -test -r Makefile && $(MAKE) clean
        dh_clean
 
 install: DH_OPTIONS=