remove obsolete, preliminary lml2 implementation
[lml.git] / 2 / debian / rules
diff --git a/2/debian/rules b/2/debian/rules
deleted file mode 100755 (executable)
index ff93e37..0000000
+++ /dev/null
@@ -1,79 +0,0 @@
-#!/usr/bin/make -f
-
-pkg    := lml2
-debpkg  := cl-lml2
-
-clc-source     := usr/share/common-lisp/source
-clc-systems    := usr/share/common-lisp/systems
-clc-lml2       := $(clc-source)/$(pkg)
-
-doc-dir                := usr/share/doc/$(debpkg)
-
-configure: configure-stamp
-configure-stamp:
-       dh_testdir
-       # Add here commands to configure the package.
-       touch configure-stamp
-
-
-build: build-stamp
-
-build-stamp: configure-stamp 
-       dh_testdir
-       # Add here commands to compile the package.
-       touch build-stamp
-
-clean:
-       dh_testdir
-       dh_testroot
-       rm -f build-stamp configure-stamp
-       # Add here commands to clean up after the build process.
-       rm -f debian/cl-lml2.postinst.* debian/cl-lml2.prerm.*
-       dh_clean
-
-install: build
-       dh_testdir
-       dh_testroot
-       dh_clean -k
-       # Add here commands to install the package into debian/lml2.
-       dh_installdirs $(clc-systems) $(clc-lml2) $(doc-dir)
-       dh_install lml2.asd lml2-tests.asd $(shell echo *.lisp) $(clc-lml2)
-       dh_link $(clc-lml2)/lml2.asd $(clc-systems)/lml2.asd
-       dh_link $(clc-lml2)/lml2-tests.asd $(clc-systems)/lml2-tests.asd
-
-# Build architecture-independent files here.
-binary-indep: build install
-
-
-# Build architecture-dependent files here.
-binary-arch: build install
-       dh_testdir
-       dh_testroot
-#      dh_installdebconf       
-       dh_installdocs doc/readme.html
-       dh_installexamples doc/Makefile doc/make.lisp $(shell echo doc/*.lml)
-#      dh_installmenu
-#      dh_installlogrotate
-#      dh_installemacsen
-#      dh_installpam
-#      dh_installmime
-#      dh_installinit
-#      dh_installcron
-#      dh_installman
-#      dh_installinfo
-#      dh_undocumented
-       dh_installchangelogs ChangeLog
-       dh_strip
-       dh_compress
-       dh_fixperms
-#      dh_makeshlibs
-       dh_installdeb
-#      dh_perl
-       dh_shlibdeps
-       dh_gencontrol
-       dh_md5sums
-       dh_builddeb
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install configure
-