Updates for new debian standards
[lml.git] / debian / rules
index 980801e80a8b86bda98a7a18ba3d5a9ad566993f..805d78e8353710a8efe1318438efdf283e820d9c 100755 (executable)
@@ -3,79 +3,53 @@
 pkg    := lml
 debpkg  := cl-lml
 
-
 clc-source     := usr/share/common-lisp/source
 clc-systems    := usr/share/common-lisp/systems
-clc-lml        := $(clc-source)/$(pkg)
-
+clc-lml                := $(clc-source)/$(pkg)
 doc-dir                := usr/share/doc/$(debpkg)
 
-
 configure: configure-stamp
 configure-stamp:
        dh_testdir
-       # Add here commands to configure the package.
        touch configure-stamp
 
-
 build: build-stamp
 
 build-stamp: configure-stamp 
        dh_testdir
-       # Add here commands to compile the package.
        touch build-stamp
 
 clean:
        dh_testdir
        dh_testroot
        rm -f build-stamp configure-stamp
-       # Add here commands to clean up after the build process.
        rm -f debian/cl-lml.postinst.* debian/cl-lml.prerm.*
        dh_clean
 
 install: build
        dh_testdir
        dh_testroot
-       dh_clean -k
-       # Add here commands to install the package into debian/lml.
+       dh_prep
        dh_installdirs $(clc-systems) $(clc-lml) $(doc-dir)
        dh_install lml.asd $(shell echo *.lisp) $(clc-lml)
        dh_install $(shell echo doc/*.html) $(doc-dir)
        dh_link $(clc-lml)/lml.asd $(clc-systems)/lml.asd
 
-# Build architecture-independent files here.
-binary-indep: build install
-
-
-# Build architecture-dependent files here.
 binary-arch: build install
-       dh_testdir
-       dh_testroot
-#      dh_installdebconf       
-       dh_installdocs
-       dh_installexamples doc/Makefile doc/make.lisp $(shell echo doc/*.lml)
-#      dh_installmenu
-#      dh_installlogrotate
-#      dh_installemacsen
-#      dh_installpam
-#      dh_installmime
-#      dh_installinit
-#      dh_installcron
-#      dh_installman
-#      dh_installinfo
-#      dh_undocumented
-       dh_installchangelogs
-       dh_strip
-       dh_compress
-       dh_fixperms
-#      dh_makeshlibs
-       dh_installdeb
-#      dh_perl
-       dh_shlibdeps
-       dh_gencontrol
-       dh_md5sums
-       dh_builddeb
+
+binary-indep: build install
+       dh_testdir -i
+       dh_testroot -i
+       dh_installdocs -i
+       dh_installexamples -i doc/Makefile doc/make.lisp $(shell echo doc/*.lml)
+       dh_installchangelogs -i
+       dh_strip -i
+       dh_compress -i
+       dh_fixperms -i
+       dh_installdeb -i
+       dh_gencontrol -i
+       dh_md5sums -i
+       dh_builddeb -i
 
 binary: binary-indep binary-arch
 .PHONY: build clean binary-indep binary-arch binary install configure
-