Update domain name to kpe.io
[lml.git] / debian / rules
index f91dab99b7247c443ddc8f9a13dc054b366e5fd6..71631b6512ffe84f37eb13bd24fd8ed2dab73681 100755 (executable)
@@ -1,98 +1,45 @@
 #!/usr/bin/make -f
 
-export DH_COMPAT=4
-
-pkg    := lml
-debpkg  := cl-lml
-
+pkg            := lml
+debpkg         := cl-lml
 
 clc-source     := usr/share/common-lisp/source
 clc-systems    := usr/share/common-lisp/systems
-clc-lml        := $(clc-source)/$(pkg)
-
-doc-dir                := usr/share/doc/$(debpkg)
+clc-files      := $(clc-source)/$(pkg)
 
 
-configure: configure-stamp
-configure-stamp:
-       dh_testdir
-       # Add here commands to configure the package.
-
-       touch configure-stamp
-
-
-build: build-stamp
-
-build-stamp: configure-stamp 
-       dh_testdir
-
-       # Add here commands to compile the package.
-
-       touch build-stamp
+build:
 
 clean:
        dh_testdir
        dh_testroot
-       rm -f build-stamp configure-stamp
-
-       # Add here commands to clean up after the build process.
-       -$(MAKE) clean
-       rm -f debian/cl-lml.postinst.* debian/cl-lml.prerm.*
-
        dh_clean
 
 install: build
        dh_testdir
        dh_testroot
-       dh_clean -k
-       dh_installdirs --all $(clc-systems) $(clc-source) 
-       dh_installdirs -p $(debpkg) $(doc-dir) $(clc-lml)/mcl 
+       dh_prep
+       dh_installdirs
+       dh_install lml.asd $(clc-files)
+       dh_install *.lisp $(clc-files)
 
-       # Add here commands to install the package into debian/lml.
-       dh_install lml.system lml.asd $(clc-systems)
-       dh_install $(shell echo *.cl) $(clc-lml)
+binary-arch:
 
-       rm -rf doc/html
-       (cd doc; tar xzf html.tar.gz; cd ..)
-       dh_install doc/html $(doc-dir)
-       rm -rf doc/html
-       cp doc/lml.pdf doc/cl-lml.pdf
-       gzip -9 doc/cl-lml.pdf
-       dh_install doc/cl-lml.pdf.gz $(doc-dir)
-
-# Build architecture-independent files here.
-binary-indep: build install
-
-
-# Build architecture-dependent files here.
-binary-arch: build install
+binary-indep: install
        dh_testdir
        dh_testroot
-#      dh_installdebconf       
-       dh_installdocs
-       dh_installexamples examples/*.cl
-#      dh_installmenu
-#      dh_installlogrotate
-#      dh_installemacsen
-#      dh_installpam
-#      dh_installmime
-#      dh_installinit
-#      dh_installcron
-#      dh_installman
-#      dh_installinfo
-#      dh_undocumented
-       dh_installchangelogs ChangeLog
-       dh_strip
+       dh_installdocs doc/*.html
+       dh_installexamples doc/Makefile doc/make.lisp doc/*.lml
+       dh_installchangelogs
+       dh_lisp
        dh_compress
        dh_fixperms
-#      dh_makeshlibs
        dh_installdeb
-#      dh_perl
-       dh_shlibdeps
        dh_gencontrol
        dh_md5sums
        dh_builddeb
 
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install configure
+binary: binary-indep
+
 
+.PHONY: build clean binary-indep binary-arch binary install