r5167: *** empty log message ***
[lml.git] / debian / rules
index 0bafb8a1c5d07ab1a994a6714fca77929a6852d3..980801e80a8b86bda98a7a18ba3d5a9ad566993f 100755 (executable)
@@ -1,7 +1,5 @@
 #!/usr/bin/make -f
 
-export DH_COMPAT=4
-
 pkg    := lml
 debpkg  := cl-lml
 
@@ -17,7 +15,6 @@ configure: configure-stamp
 configure-stamp:
        dh_testdir
        # Add here commands to configure the package.
-
        touch configure-stamp
 
 
@@ -25,9 +22,7 @@ build: build-stamp
 
 build-stamp: configure-stamp 
        dh_testdir
-
        # Add here commands to compile the package.
-
        touch build-stamp
 
 clean:
@@ -44,7 +39,7 @@ install: build
        dh_clean -k
        # Add here commands to install the package into debian/lml.
        dh_installdirs $(clc-systems) $(clc-lml) $(doc-dir)
-       dh_install lml.asd $(shell echo *.cl) $(clc-lml)
+       dh_install lml.asd $(shell echo *.lisp) $(clc-lml)
        dh_install $(shell echo doc/*.html) $(doc-dir)
        dh_link $(clc-lml)/lml.asd $(clc-systems)/lml.asd
 
@@ -58,7 +53,7 @@ binary-arch: build install
        dh_testroot
 #      dh_installdebconf       
        dh_installdocs
-       dh_installexamples doc/Makefile doc/make.cl $(shell echo doc/*.lml)
+       dh_installexamples doc/Makefile doc/make.lisp $(shell echo doc/*.lml)
 #      dh_installmenu
 #      dh_installlogrotate
 #      dh_installemacsen