r5167: *** empty log message ***
[lml.git] / debian / rules
index d6aa11bfe10d53d3e88f1c70a951bca351d5761e..980801e80a8b86bda98a7a18ba3d5a9ad566993f 100755 (executable)
@@ -1,7 +1,5 @@
 #!/usr/bin/make -f
 
-export DH_COMPAT=4
-
 pkg    := lml
 debpkg  := cl-lml
 
@@ -17,7 +15,6 @@ configure: configure-stamp
 configure-stamp:
        dh_testdir
        # Add here commands to configure the package.
-
        touch configure-stamp
 
 
@@ -25,33 +22,26 @@ build: build-stamp
 
 build-stamp: configure-stamp 
        dh_testdir
-
        # Add here commands to compile the package.
-
        touch build-stamp
 
 clean:
        dh_testdir
        dh_testroot
        rm -f build-stamp configure-stamp
-
        # Add here commands to clean up after the build process.
-       -$(MAKE) clean
        rm -f debian/cl-lml.postinst.* debian/cl-lml.prerm.*
-
        dh_clean
 
 install: build
        dh_testdir
        dh_testroot
        dh_clean -k
-       dh_installdirs --all $(clc-systems) $(clc-source) 
-       dh_installdirs -p $(debpkg) $(doc-dir) $(clc-lml)/mcl 
-
        # Add here commands to install the package into debian/lml.
-       dh_install lml.system lml.asd $(clc-systems)
-       dh_install $(shell echo *.cl) $(clc-lml)
-       dh_install docs/* $(doc-dir)
+       dh_installdirs $(clc-systems) $(clc-lml) $(doc-dir)
+       dh_install lml.asd $(shell echo *.lisp) $(clc-lml)
+       dh_install $(shell echo doc/*.html) $(doc-dir)
+       dh_link $(clc-lml)/lml.asd $(clc-systems)/lml.asd
 
 # Build architecture-independent files here.
 binary-indep: build install
@@ -63,7 +53,7 @@ binary-arch: build install
        dh_testroot
 #      dh_installdebconf       
        dh_installdocs
-       dh_installexamples examples/*.cl
+       dh_installexamples doc/Makefile doc/make.lisp $(shell echo doc/*.lml)
 #      dh_installmenu
 #      dh_installlogrotate
 #      dh_installemacsen
@@ -74,7 +64,7 @@ binary-arch: build install
 #      dh_installman
 #      dh_installinfo
 #      dh_undocumented
-       dh_installchangelogs ChangeLog
+       dh_installchangelogs
        dh_strip
        dh_compress
        dh_fixperms