r4534: Auto commit for Debian build
[lml.git] / debian / rules
index a93a0ebc799941f4e19dbd0b57e649c096b121cf..d1abbd536461145565617e96c5479785ee1956cb 100755 (executable)
@@ -17,7 +17,6 @@ configure: configure-stamp
 configure-stamp:
        dh_testdir
        # Add here commands to configure the package.
-
        touch configure-stamp
 
 
@@ -25,9 +24,7 @@ build: build-stamp
 
 build-stamp: configure-stamp 
        dh_testdir
-
        # Add here commands to compile the package.
-
        touch build-stamp
 
 clean:
@@ -44,8 +41,9 @@ install: build
        dh_clean -k
        # Add here commands to install the package into debian/lml.
        dh_installdirs $(clc-systems) $(clc-lml) $(doc-dir)
-       dh_install lml.system lml.asd $(shell echo *.cl) $(clc-lml)
+       dh_install lml.asd lml-base.asd $(shell echo *.lisp) $(clc-lml)
        dh_install $(shell echo doc/*.html) $(doc-dir)
+       dh_link $(clc-lml)/lml-base.asd $(clc-systems)/lml-base.asd
        dh_link $(clc-lml)/lml.asd $(clc-systems)/lml.asd
 
 # Build architecture-independent files here.
@@ -58,7 +56,7 @@ binary-arch: build install
        dh_testroot
 #      dh_installdebconf       
        dh_installdocs
-       dh_installexamples doc/Makefile doc/make.cl $(shell echo doc/*.lml)
+       dh_installexamples doc/Makefile doc/make.lisp $(shell echo doc/*.lml)
 #      dh_installmenu
 #      dh_installlogrotate
 #      dh_installemacsen