Updates for new debian standards
[lml2.git] / debian / rules
index a73b2651a0fff7956c0b64a04afff8c9b2744c75..0efeaeab3ba5b64e30ba5e9e876263815bf887a4 100755 (executable)
@@ -6,36 +6,30 @@ debpkg  := cl-lml2
 clc-source     := usr/share/common-lisp/source
 clc-systems    := usr/share/common-lisp/systems
 clc-lml2       := $(clc-source)/$(pkg)
-
 doc-dir                := usr/share/doc/$(debpkg)
 
 configure: configure-stamp
 configure-stamp:
        dh_testdir
-       # Add here commands to configure the package.
        touch configure-stamp
 
-
 build: build-stamp
 
 build-stamp: configure-stamp 
        dh_testdir
-       # Add here commands to compile the package.
        touch build-stamp
 
 clean:
        dh_testdir
        dh_testroot
        rm -f build-stamp configure-stamp
-       # Add here commands to clean up after the build process.
        rm -f debian/cl-lml2.postinst.* debian/cl-lml2.prerm.*
        dh_clean
 
 install: build
        dh_testdir
        dh_testroot
-       dh_clean -k
-       # Add here commands to install the package into debian/lml2.
+       dh_prep
        dh_installdirs $(clc-systems) $(clc-lml2) $(doc-dir)
        dh_install lml2.asd lml2-tests.asd $(shell echo *.lisp) $(clc-lml2)
        dh_link $(clc-lml2)/lml2.asd $(clc-systems)/lml2.asd
@@ -43,35 +37,19 @@ install: build
 
 binary-arch: build install
 
-# Build architecture-independent files here.
 binary-indep: build install
-       dh_testdir
-       dh_testroot
-#      dh_installdebconf       
-       dh_installdocs doc/readme.html
-       dh_installexamples doc/Makefile doc/make.lisp $(shell echo doc/*.lml)
-#      dh_installmenu
-#      dh_installlogrotate
-#      dh_installemacsen
-#      dh_installpam
-#      dh_installmime
-#      dh_installinit
-#      dh_installcron
-#      dh_installman
-#      dh_installinfo
-#      dh_undocumented
-       dh_installchangelogs ChangeLog
-       dh_strip
-       dh_compress
-       dh_fixperms
-#      dh_makeshlibs
-       dh_installdeb
-#      dh_perl
-       dh_shlibdeps
-       dh_gencontrol
-       dh_md5sums
-       dh_builddeb
+       dh_testdir -i
+       dh_testroot -i
+       dh_installdocs -i doc/readme.html
+       dh_installexamples -i doc/Makefile doc/make.lisp $(shell echo doc/*.lml)
+       dh_installchangelogs -i ChangeLog
+       dh_strip -i
+       dh_compress -i
+       dh_fixperms -i
+       dh_installdeb -i
+       dh_gencontrol -i
+       dh_md5sums -i
+       dh_builddeb -i
 
 binary: binary-indep binary-arch
 .PHONY: build clean binary-arch binary-indep binary install configure
-