fix line in changelog
[reversi.git] / debian / rules
index c37f3804d5494f7086070348840c730cd4100e07..071560bb0dbbc8a5a742be9abb703f1d332caf9d 100755 (executable)
@@ -3,19 +3,15 @@
 pkg    := reversi
 debpkg := cl-reversi
 
-
 clc-source     := usr/share/common-lisp/source
 clc-systems    := usr/share/common-lisp/systems
 clc-reversi    := $(clc-source)/$(pkg)
-
 doc-dir                := usr/share/doc/$(debpkg)
 
 
 configure: configure-stamp
 configure-stamp:
        dh_testdir
-       # Add here commands to configure the package.
-
        touch configure-stamp
 
 
@@ -23,44 +19,37 @@ build: build-stamp
 
 build-stamp: configure-stamp 
        dh_testdir
-       # Add here commands to compile the package.
        touch build-stamp
 
 clean:
        dh_testdir
        dh_testroot
        rm -f build-stamp configure-stamp
-       # Add here commands to clean up after the build process.
        rm -f debian/cl-reversi.postinst.* debian/cl-reversi.prerm.*
        dh_clean
 
 install: build
        dh_testdir
        dh_testroot
-       dh_clean -k
-       # Add here commands to install the package into debian/reversi.
+       dh_prep
        dh_installdirs -p $(debpkg) $(clc-systems) $(clc-reversi)
        dh_install -p $(debpkg) reversi.asd $(shell echo *.lisp *.dat) $(clc-reversi)
        dh_link -p $(debpkg) $(clc-reversi)/reversi.asd $(clc-systems)/reversi.asd
 
-# Build architecture-independent files here.
 binary-indep: build install
+       dh_testdir -i
+       dh_testroot -i
+       dh_installdocs -i
+       dh_installchangelogs -i
+       dh_strip -i
+       dh_compress -i
+       dh_fixperms -i
+       dh_installdeb -i
+       dh_gencontrol -i
+       dh_md5sums -i
+       dh_builddeb -i
 
-
-# Build architecture-dependent files here.
 binary-arch: build install
-       dh_testdir
-       dh_testroot
-       dh_installdocs
-       dh_installchangelogs
-       dh_strip
-       dh_compress
-       dh_fixperms
-       dh_installdeb
-       dh_shlibdeps
-       dh_gencontrol
-       dh_md5sums
-       dh_builddeb
 
 binary: binary-indep binary-arch
 .PHONY: build clean binary-indep binary-arch binary install configure