r4897: *** empty log message ***
[rt.git] / debian / rules
index 3b45265c1058a290cbd28f1f4c281e4c62a76630..ea99d99b53bcf51bab7e56edbe33f9af89d15ab2 100755 (executable)
@@ -1,7 +1,5 @@
 #!/usr/bin/make -f
 
-export DH_COMPAT=4
-
 pkg    := rt
 debpkg  := cl-rt
 
@@ -42,7 +40,7 @@ install: build
        dh_clean -k
        # Add here commands to install the package into debian/rt.
        dh_installdirs $(clc-systems) $(clc-rt)
-       dh_install debian/rt.asd $(shell echo *.lisp) $(clc-rt)
+       dh_install rt.asd rt.lisp $(clc-rt)
        dh_link $(clc-rt)/rt.asd $(clc-systems)/rt.asd
 
 # Build architecture-independent files here.
@@ -53,7 +51,8 @@ binary-indep: build install
 binary-arch: build install
        dh_testdir
        dh_testroot
-       dh_installdocs
+       dh_installdocs rt-doc.txt
+       dh_installexamples rt-test.lisp
        dh_installchangelogs
        dh_strip
        dh_compress