r8138: Automated commit for uffi debian-version-1.4.0-1
[uffi.git] / debian / rules
index ff1a1d14d3de49a3c198dfa234c527cf08483b46..6423b2cf779771bc925f85e552d39f346885a543 100755 (executable)
@@ -25,7 +25,7 @@ build: build-stamp
 build-stamp: configure-stamp 
        dh_testdir
        # Add here commands to compile the package.
-       (cd tests; make linux)
+       (cd tests; make)
        touch build-stamp
 
 clean:
@@ -60,8 +60,8 @@ install: build
 
        dh_installdirs -p $(debpkg-tests) $(clc-tests)/tests $(lib-dir)
        dh_install -p $(debpkg-tests) $(pkg-tests).asd $(clc-tests)
-       dh_install -p $(debpkg-tests) "tests/*.lisp" $(clc-tests)/tests
-       dh_install -p $(debpkg-tests) "tests/uffi-c-test-lib.so" $(lib-dir)
+       dh_install -p $(debpkg-tests) tests/*.lisp tests/*.c $(clc-tests)/tests
+       dh_install -p $(debpkg-tests) tests/uffi-c-test-lib.so $(lib-dir)
        dh_link -p $(debpkg-tests) $(clc-tests)/$(pkg-tests).asd $(clc-systems)/$(pkg-tests).asd
 
 # Build architecture-independent files here.