r11765: do not miss make clean errors
[uffi.git] / debian / rules
index ff1a1d14d3de49a3c198dfa234c527cf08483b46..07fc4a220237d05e8fbefc10d6ac307568f34eb8 100755 (executable)
@@ -25,7 +25,7 @@ build: build-stamp
 build-stamp: configure-stamp 
        dh_testdir
        # Add here commands to compile the package.
-       (cd tests; make linux)
+       (cd tests; make)
        touch build-stamp
 
 clean:
@@ -33,9 +33,10 @@ clean:
        dh_testroot
        rm -f build-stamp configure-stamp
        # Add here commands to clean up after the build process.
-       -$(MAKE) clean
+       $(MAKE) clean
        (cd tests; make clean)
        rm -f debian/$(debpkg).postinst.* debian/$(debpkg).prerm.*
+       rm -f doc/cl-uffi.pdf.gz
        dh_clean
 
 install: build
@@ -55,13 +56,14 @@ install: build
        dh_install doc/html $(doc-dir)
        rm -rf doc/html
        cp doc/uffi.pdf doc/cl-uffi.pdf
+       rm -f doc/cl-uffi.pdf.gz # ensure file not present before making gz
        gzip -9 doc/cl-uffi.pdf
        dh_install doc/cl-uffi.pdf.gz $(doc-dir)
 
        dh_installdirs -p $(debpkg-tests) $(clc-tests)/tests $(lib-dir)
        dh_install -p $(debpkg-tests) $(pkg-tests).asd $(clc-tests)
-       dh_install -p $(debpkg-tests) "tests/*.lisp" $(clc-tests)/tests
-       dh_install -p $(debpkg-tests) "tests/uffi-c-test-lib.so" $(lib-dir)
+       dh_install -p $(debpkg-tests) tests/*.lisp tests/*.c $(clc-tests)/tests
+       dh_install -p $(debpkg-tests) tests/*.so $(lib-dir)
        dh_link -p $(debpkg-tests) $(clc-tests)/$(pkg-tests).asd $(clc-systems)/$(pkg-tests).asd
 
 # Build architecture-independent files here.