r4699: *** empty log message ***
[uffi.git] / debian / rules
index f561721db3bb06d31caa9f89dcb9d43807fb5320..36ea0d7c76a0d893e3fa4bd926dd39dfdfb6f409 100755 (executable)
@@ -1,23 +1,22 @@
 #!/usr/bin/make -f
 
-export DH_COMPAT=4
-
-pkg    := uffi
-debpkg  := cl-uffi
+pkg            := uffi
+pkg-tests      := $(pkg)-tests 
+debpkg         := cl-$(pkg)
+debpkg-tests   := $(debpkg)-tests
 
 
 clc-source     := usr/share/common-lisp/source
 clc-systems    := usr/share/common-lisp/systems
-clc-uffi       := $(clc-source)/$(pkg)
-
+clc-files      := $(clc-source)/$(pkg)
+clc-tests      := $(clc-source)/$(pkg-tests)
 doc-dir                := usr/share/doc/$(debpkg)
-
+lib-dir                := usr/lib
 
 configure: configure-stamp
 configure-stamp:
        dh_testdir
        # Add here commands to configure the package.
-
        touch configure-stamp
 
 
@@ -25,20 +24,19 @@ build: build-stamp
 
 build-stamp: configure-stamp 
        dh_testdir
-
        # Add here commands to compile the package.
-
+       (cd examples; make linux)
        touch build-stamp
 
 clean:
        dh_testdir
        dh_testroot
        rm -f build-stamp configure-stamp
-
        # Add here commands to clean up after the build process.
        -$(MAKE) clean
-       rm -f debian/cl-uffi.postinst.* debian/cl-uffi.prerm.*
-
+       cd examples
+       make clean
+       rm -f debian/$(debpkg).postinst.* debian/$(debpkg).prerm.*
        dh_clean
 
 install: build
@@ -46,12 +44,18 @@ install: build
        dh_testroot
        dh_clean -k
        dh_installdirs --all $(clc-systems) $(clc-source) 
-       dh_installdirs -p $(debpkg) $(doc-dir) $(clc-uffi)/src
+       dh_installdirs -p $(debpkg) $(doc-dir) $(clc-files)/src
 
        # Add here commands to install the package into debian/uffi.
-       dh_install uffi.asd $(clc-uffi)
-       dh_install "src/*.lisp" $(clc-uffi)/src
-       dh_link $(clc-uffi)/uffi.asd $(clc-systems)/uffi.asd
+       dh_install $(pkg).asd $(clc-files)
+       dh_install "src/*.lisp" $(clc-files)/src
+       dh_link $(clc-files)/$(pkg).asd $(clc-systems)/$(pkg).asd
+
+       dh_installdirs -p $(debpkg-tests) $(clc-tests)/tests $(lib-dir)
+       dh_install $(debpkg-tests) $(pkg-tests).asd $(clc-tests)
+       dh_install $(debpkg-tests) "examples/*.lisp" $(clc-tests)/tests
+       dh_install $(debpkg-tests) "examples/c-test-fns.so" $(lib-dir)
+       dh_link $(debpkg-tests) $(clc-tests)/$(pkg-tests).asd $(clc-systems)/$(clc-tests).$(pkg-tests)asd
 
        rm -rf doc/html
        (cd doc; tar xzf html.tar.gz; cd ..)