r11710: fix build-twice-in-a-row
[uffi.git] / debian / rules
index 79388a134b60781de72d1fcaf48b3e7ecd230c32..3b3bb574950d04572b7dc1cc6c0c81ce5a5b6d8f 100755 (executable)
@@ -36,6 +36,7 @@ clean:
        -$(MAKE) clean
        (cd tests; make clean)
        rm -f debian/$(debpkg).postinst.* debian/$(debpkg).prerm.*
+       rm -f doc/cl-uffi.pdf.gz
        dh_clean
 
 install: build
@@ -55,6 +56,7 @@ install: build
        dh_install doc/html $(doc-dir)
        rm -rf doc/html
        cp doc/uffi.pdf doc/cl-uffi.pdf
+       rm -f doc/cl-uffi.pdf.gz # ensure file not present before making gz
        gzip -9 doc/cl-uffi.pdf
        dh_install doc/cl-uffi.pdf.gz $(doc-dir)