Add minor upstream changes; conform new debian standards
[uffi.git] / debian / rules
index 92347b96b3e49efa69bd06344c1bb8442dad109a..8f8867f7df476983e2f68951d0a9a325f145a1f3 100755 (executable)
@@ -5,7 +5,6 @@ pkg-tests       := $(pkg)-tests
 debpkg         := cl-$(pkg)
 debpkg-tests   := $(debpkg)-tests
 
-
 clc-source     := usr/share/common-lisp/source
 clc-systems    := usr/share/common-lisp/systems
 clc-files      := $(clc-source)/$(pkg)
@@ -16,7 +15,6 @@ lib-dir               := usr/lib/uffi
 configure: configure-stamp
 configure-stamp:
        dh_testdir
-       # Add here commands to configure the package.
        touch configure-stamp
 
 
@@ -24,7 +22,6 @@ build: build-stamp
 
 build-stamp: configure-stamp 
        dh_testdir
-       # Add here commands to compile the package.
        (cd tests; make)
        touch build-stamp
 
@@ -32,7 +29,6 @@ clean:
        dh_testdir
        dh_testroot
        rm -f build-stamp configure-stamp
-       # Add here commands to clean up after the build process.
        $(MAKE) clean
        (cd tests; make clean)
        rm -f debian/$(debpkg).postinst.* debian/$(debpkg).prerm.*
@@ -42,10 +38,8 @@ clean:
 install: build
        dh_testdir
        dh_testroot
-       dh_clean -k
+       dh_prep
        dh_installdirs --all $(clc-systems) $(clc-source) 
-
-       # Add here commands to install the package into debian/uffi.
        dh_installdirs -p $(debpkg) $(doc-dir) $(clc-files)/src
        dh_install $(pkg).asd $(clc-files)
        dh_install "src/*.lisp" $(clc-files)/src
@@ -66,7 +60,6 @@ install: build
        dh_install -p $(debpkg-tests) tests/*.so $(lib-dir)
        dh_link -p $(debpkg-tests) $(clc-tests)/$(pkg-tests).asd $(clc-systems)/$(pkg-tests).asd
 
-# Build architecture-independent files here.
 binary-indep: build install
        dh_testdir -i
        dh_testroot -i
@@ -84,7 +77,6 @@ binary-indep: build install
        dh_md5sums -i
        dh_builddeb -i
 
-# Build architecture-dependent files here.
 binary-arch: build install
        dh_testdir -a
        dh_testroot -a