* tests/foreign-loader.lisp: Commit patch from Luis Oliveira
[uffi.git] / debian / rules
index 36ea0d7c76a0d893e3fa4bd926dd39dfdfb6f409..92347b96b3e49efa69bd06344c1bb8442dad109a 100755 (executable)
@@ -1,7 +1,7 @@
 #!/usr/bin/make -f
 
 pkg            := uffi
-pkg-tests      := $(pkg)-tests 
+pkg-tests      := $(pkg)-tests
 debpkg         := cl-$(pkg)
 debpkg-tests   := $(debpkg)-tests
 
@@ -11,7 +11,7 @@ clc-systems   := usr/share/common-lisp/systems
 clc-files      := $(clc-source)/$(pkg)
 clc-tests      := $(clc-source)/$(pkg-tests)
 doc-dir                := usr/share/doc/$(debpkg)
-lib-dir                := usr/lib
+lib-dir                := usr/lib/uffi
 
 configure: configure-stamp
 configure-stamp:
@@ -25,7 +25,7 @@ build: build-stamp
 build-stamp: configure-stamp 
        dh_testdir
        # Add here commands to compile the package.
-       (cd examples; make linux)
+       (cd tests; make)
        touch build-stamp
 
 clean:
@@ -33,10 +33,10 @@ clean:
        dh_testroot
        rm -f build-stamp configure-stamp
        # Add here commands to clean up after the build process.
-       -$(MAKE) clean
-       cd examples
-       make clean
+       $(MAKE) clean
+       (cd tests; make clean)
        rm -f debian/$(debpkg).postinst.* debian/$(debpkg).prerm.*
+       rm -f doc/cl-uffi.pdf.gz
        dh_clean
 
 install: build
@@ -44,59 +44,62 @@ install: build
        dh_testroot
        dh_clean -k
        dh_installdirs --all $(clc-systems) $(clc-source) 
-       dh_installdirs -p $(debpkg) $(doc-dir) $(clc-files)/src
 
        # Add here commands to install the package into debian/uffi.
+       dh_installdirs -p $(debpkg) $(doc-dir) $(clc-files)/src
        dh_install $(pkg).asd $(clc-files)
        dh_install "src/*.lisp" $(clc-files)/src
        dh_link $(clc-files)/$(pkg).asd $(clc-systems)/$(pkg).asd
 
-       dh_installdirs -p $(debpkg-tests) $(clc-tests)/tests $(lib-dir)
-       dh_install $(debpkg-tests) $(pkg-tests).asd $(clc-tests)
-       dh_install $(debpkg-tests) "examples/*.lisp" $(clc-tests)/tests
-       dh_install $(debpkg-tests) "examples/c-test-fns.so" $(lib-dir)
-       dh_link $(debpkg-tests) $(clc-tests)/$(pkg-tests).asd $(clc-systems)/$(clc-tests).$(pkg-tests)asd
-
        rm -rf doc/html
        (cd doc; tar xzf html.tar.gz; cd ..)
        dh_install doc/html $(doc-dir)
        rm -rf doc/html
        cp doc/uffi.pdf doc/cl-uffi.pdf
+       rm -f doc/cl-uffi.pdf.gz # ensure file not present before making gz
        gzip -9 doc/cl-uffi.pdf
        dh_install doc/cl-uffi.pdf.gz $(doc-dir)
 
+       dh_installdirs -p $(debpkg-tests) $(clc-tests)/tests $(lib-dir)
+       dh_install -p $(debpkg-tests) $(pkg-tests).asd $(clc-tests)
+       dh_install -p $(debpkg-tests) tests/*.lisp tests/*.c $(clc-tests)/tests
+       dh_install -p $(debpkg-tests) tests/*.so $(lib-dir)
+       dh_link -p $(debpkg-tests) $(clc-tests)/$(pkg-tests).asd $(clc-systems)/$(pkg-tests).asd
+
 # Build architecture-independent files here.
 binary-indep: build install
-
+       dh_testdir -i
+       dh_testroot -i
+       dh_installdocs -i
+       dh_installexamples -i examples/*.lisp
+       dh_installmenu -i
+       dh_installcron -i
+       dh_installinfo -i
+       dh_installchangelogs ChangeLog -i
+       dh_link -i
+       dh_compress -i
+       dh_fixperms -i
+       dh_installdeb -i
+       dh_gencontrol -i
+       dh_md5sums -i
+       dh_builddeb -i
 
 # Build architecture-dependent files here.
 binary-arch: build install
-       dh_testdir
-       dh_testroot
-#      dh_installdebconf       
-       dh_installdocs
-       dh_installexamples examples/*.lisp
-#      dh_installmenu
-#      dh_installlogrotate
-#      dh_installemacsen
-#      dh_installpam
-#      dh_installmime
-#      dh_installinit
-#      dh_installcron
-#      dh_installman
-#      dh_installinfo
-#      dh_undocumented
-       dh_installchangelogs ChangeLog
-       dh_strip
-       dh_compress
-       dh_fixperms
-#      dh_makeshlibs
-       dh_installdeb
-#      dh_perl
-       dh_shlibdeps
-       dh_gencontrol
-       dh_md5sums
-       dh_builddeb
+       dh_testdir -a
+       dh_testroot -a
+       dh_installdocs -a
+       dh_installchangelogs ChangeLog -a
+       dh_strip -a
+       dh_link -a
+       dh_compress -a
+       dh_fixperms -a
+       dh_installmenu -a
+       dh_installdeb -a
+       dh_shlibdeps -a
+       dh_gencontrol -a
+       dh_md5sums -a
+       dh_builddeb -a
 
 binary: binary-indep binary-arch
 .PHONY: build clean binary-indep binary-arch binary install configure