r11566: add debian files
[cluck.git] / debian / rules
diff --git a/debian/rules b/debian/rules
new file mode 100755 (executable)
index 0000000..30e5ea6
--- /dev/null
@@ -0,0 +1,55 @@
+#!/usr/bin/make -f
+
+pkg            := cluck
+debpkg         := cl-$(pkg)
+
+clc-source     := usr/share/common-lisp/source
+clc-systems    := usr/share/common-lisp/systems
+clc-files      := $(clc-source)/$(pkg)
+clc-tests      := $(clc-source)/$(pkg-tests)
+
+configure: configure-stamp
+configure-stamp:
+       dh_testdir
+       touch configure-stamp
+
+
+build: build-stamp
+
+build-stamp: configure-stamp 
+       dh_testdir
+       touch build-stamp
+
+clean:
+       dh_testdir
+       dh_testroot
+       rm -f build-stamp configure-stamp
+       dh_clean
+
+install: build
+       dh_testdir
+       dh_testroot
+       dh_clean -k
+       dh_installdirs --all $(clc-systems) $(clc-source) 
+
+       # Add here commands to install the package into debian/uffi.
+       dh_installdirs -p $(debpkg) $(doc-dir) $(clc-files)/src
+       dh_install $(pkg).asd $(clc-files)
+       dh_install "src/*.lisp" $(clc-files)/src
+       dh_link $(clc-files)/$(pkg).asd $(clc-systems)/$(pkg).asd
+
+binary: build install
+       dh_testdir
+       dh_testroot
+       dh_installdocs
+       dh_installmenu
+       dh_link
+       dh_compress
+       dh_fixperms
+       dh_installdeb
+       dh_gencontrol
+       dh_md5sums
+       dh_builddeb
+
+.PHONY: build clean binary install configure
+