Updates for new debian standards
[cl-modlisp.git] / debian / rules
index 3c54a642c348512f251d46fb7a86908506c60d91..de6f05f931594ca3cfb75c0d9a198bc3be757f45 100755 (executable)
@@ -3,60 +3,50 @@
 pkg    := modlisp
 debpkg  := cl-modlisp
 
-
 clc-source     := usr/share/common-lisp/source
 clc-systems    := usr/share/common-lisp/systems
 clc-modlisp    := $(clc-source)/$(pkg)
-
 doc-dir                := usr/share/doc/$(debpkg)
 
-
 configure: configure-stamp
 configure-stamp:
        dh_testdir
-       # Add here commands to configure the package.
        touch configure-stamp
 
-
 build: build-stamp
 
 build-stamp: configure-stamp 
        dh_testdir
-       # Add here commands to compile the package.
        touch build-stamp
 
 clean:
        dh_testdir
        dh_testroot
        rm -f build-stamp configure-stamp
-       # Add here commands to clean up after the build process.
        rm -f debian/cl-modlisp.postinst.* debian/cl-modlisp.prerm.*
        dh_clean
 
 install: build
        dh_testdir
        dh_testroot
-       dh_clean -k
-       # Add here commands to install the package into debian/modlisp.
+       dh_prep
        dh_installdirs $(clc-systems) $(clc-modlisp) 
        dh_install modlisp.asd $(shell echo *.lisp) $(clc-modlisp)
        dh_link $(clc-modlisp)/modlisp.asd $(clc-systems)/modlisp.asd
 
 binary-indep: build install
-       dh_testdir
-       dh_testroot
-       dh_installdocs doc/readme.html
-       dh_installexamples 
-       dh_installchangelogs ChangeLog
-       dh_strip
-       dh_compress
-       dh_fixperms
-       dh_installdeb
-       dh_shlibdeps
-       dh_gencontrol
-       dh_md5sums
-       dh_builddeb
-
+       dh_testdir -i
+       dh_testroot -i
+       dh_installdocs -i doc/readme.html
+       dh_installexamples -i
+       dh_installchangelogs -i ChangeLog
+       dh_strip -i
+       dh_compress -i
+       dh_fixperms -i
+       dh_installdeb -i
+       dh_gencontrol -i
+       dh_md5sums -i
+       dh_builddeb -i
 
 binary-arch: build install