Update domain name to kpe.io
[cl-modlisp.git] / debian / rules
index bd42b3703f656004686112adc905290783772adc..17da9dc7118a6204ea146bffc86e329f0e21ef7b 100755 (executable)
@@ -1,80 +1,45 @@
 #!/usr/bin/make -f
 
-pkg    := modlisp
-debpkg  := cl-modlisp
-
+pkg            := modlisp
+debpkg         := cl-modlisp
 
 clc-source     := usr/share/common-lisp/source
 clc-systems    := usr/share/common-lisp/systems
-clc-modlisp    := $(clc-source)/$(pkg)
-
+clc-files      := $(clc-source)/$(pkg)
 doc-dir                := usr/share/doc/$(debpkg)
 
-
-configure: configure-stamp
-configure-stamp:
-       dh_testdir
-       # Add here commands to configure the package.
-       touch configure-stamp
-
-
-build: build-stamp
-
-build-stamp: configure-stamp 
-       dh_testdir
-       # Add here commands to compile the package.
-       touch build-stamp
+build:
 
 clean:
        dh_testdir
        dh_testroot
-       rm -f build-stamp configure-stamp
-       # Add here commands to clean up after the build process.
-       rm -f debian/cl-modlisp.postinst.* debian/cl-modlisp.prerm.*
        dh_clean
 
 install: build
        dh_testdir
        dh_testroot
-       dh_clean -k
-       # Add here commands to install the package into debian/modlisp.
-       dh_installdirs $(clc-systems) $(clc-modlisp) 
-       dh_install modlisp.asd $(shell echo *.lisp) $(clc-modlisp)
-       dh_link $(clc-modlisp)/modlisp.asd $(clc-systems)/modlisp.asd
-
-# Build architecture-independent files here.
-binary-indep: build install
+       dh_prep
+       dh_installdirs
+       dh_install modlisp.asd $(clc-files)
+       dh_install *.lisp $(clc-files)
 
-
-# Build architecture-dependent files here.
-binary-arch: build install
+binary-indep: install
        dh_testdir
        dh_testroot
-#      dh_installdebconf       
-       dh_installdocs README
-       dh_installexamples 
-#      dh_installmenu
-#      dh_installlogrotate
-#      dh_installemacsen
-#      dh_installpam
-#      dh_installmime
-#      dh_installinit
-#      dh_installcron
-#      dh_installman
-#      dh_installinfo
-#      dh_undocumented
-       dh_installchangelogs Changelog
-       dh_strip
+       dh_installdocs doc/readme.html
+       dh_installexamples
+       dh_installchangelogs
+       dh_lisp
        dh_compress
        dh_fixperms
-#      dh_makeshlibs
        dh_installdeb
-#      dh_perl
-       dh_shlibdeps
        dh_gencontrol
        dh_md5sums
        dh_builddeb
 
+binary-arch:
+
 binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install configure
 
+
+.PHONY: build clean binary-indep binary-arch binary install