Updates for new debian standards
[cl-photo.git] / debian / rules
index 2efdedc99becfa15186746b31459b4b955805bc2..c3eea0fb8ef662daa64864eec1402c6d4f3f50cf 100755 (executable)
@@ -6,71 +6,48 @@ debpkg  := cl-photo
 clc-source     := usr/share/common-lisp/source
 clc-systems    := usr/share/common-lisp/systems
 clc-photo      := $(clc-source)/$(pkg)
-
 doc-dir                := usr/share/doc/$(debpkg)
 
 configure: configure-stamp
 configure-stamp:
        dh_testdir
-       # Add here commands to configure the package.
        touch configure-stamp
 
-
 build: build-stamp
 
 build-stamp: configure-stamp 
        dh_testdir
-       # Add here commands to compile the package.
        touch build-stamp
 
 clean:
        dh_testdir
        dh_testroot
        rm -f build-stamp configure-stamp
-       # Add here commands to clean up after the build process.
        rm -f debian/cl-photo.postinst.* debian/cl-photo.prerm.*
-       dh_clean
+       dh_prep
 
 install: build
        dh_testdir
        dh_testroot
-       dh_clean -k
-       # Add here commands to install the package into debian/photo.
+       dh_prep
        dh_installdirs $(clc-systems) $(clc-photo) $(doc-dir)
        dh_install cl-photo.asd $(shell echo *.lisp) $(clc-photo)
        dh_link $(clc-photo)/cl-photo.asd $(clc-systems)/cl-photo.asd
 
-# Build architecture-independent files here.
 binary-indep: build install
+       dh_testdir -i
+       dh_testroot -i
+       dh_installdocs -i doc/readme.html
+       dh_installchangelogs -i
+       dh_strip -i
+       dh_compress -i
+       dh_fixperms -i
+       dh_installdeb -i
+       dh_gencontrol -i
+       dh_md5sums -i
+       dh_builddeb -i
 
-
-# Build architecture-dependent files here.
 binary-arch: build install
-       dh_testdir
-       dh_testroot
-#      dh_installdebconf       
-       dh_installdocs doc/readme.html
-#      dh_installmenu
-#      dh_installlogrotate
-#      dh_installemacsen
-#      dh_installpam
-#      dh_installmime
-#      dh_installinit
-#      dh_installcron
-#      dh_installman
-#      dh_installinfo
-#      dh_undocumented
-       dh_installchangelogs 
-       dh_strip
-       dh_compress
-       dh_fixperms
-#      dh_makeshlibs
-       dh_installdeb
-#      dh_perl
-       dh_shlibdeps
-       dh_gencontrol
-       dh_md5sums
-       dh_builddeb
 
 binary: binary-indep binary-arch
 .PHONY: build clean binary-indep binary-arch binary install configure