Updates for new debian standards
[cl-readline.git] / debian / rules
index 5f75dc03796a1815d3a1fc8594e65e0f58bd071f..af34103ad630c09261402ffc9b57a7b29efa09e7 100755 (executable)
@@ -8,13 +8,11 @@ clc-systems   := usr/share/common-lisp/systems
 clc-files      := $(clc-source)/$(pkg)
 doc-dir                := usr/share/doc/$(debpkg)
 lib-dir                := usr/lib/cl-readline
-
 source-files   := $(wildcard *.lisp)
 
 configure: configure-stamp
 configure-stamp:
        dh_testdir
-       # Add here commands to configure the package.
        touch configure-stamp
 
 
@@ -22,7 +20,6 @@ build: build-stamp
 
 build-stamp: configure-stamp 
        dh_testdir
-       # Add here commands to compile the package.
        $(MAKE)
        touch build-stamp
 
@@ -30,7 +27,6 @@ clean:
        dh_testdir
        dh_testroot
        rm -f build-stamp configure-stamp
-       # Add here commands to clean up after the build process.
        rm -f debian/$(debpkg).postinst.* debian/$(debpkg).prerm.*
        rm -f *.o *.so
        dh_clean
@@ -38,44 +34,27 @@ clean:
 install: build
        dh_testdir
        dh_testroot
-       dh_clean -k
-       # Add here commands to install the package into debian/kmrcl.
+       dh_prep
        dh_installdirs $(clc-systems) $(clc-files) $(clc-tests)
        dh_install $(pkg).asd $(source-files) $(clc-files)
        dh_link $(clc-files)/$(pkg).asd $(clc-systems)/$(pkg).asd
        dh_install *.so $(lib-dir)
 
-# Build architecture-independent files here.
 binary-indep: build install
 
-
-# Build architecture-dependent files here.
 binary-arch: build install
-       dh_testdir
-       dh_testroot
-#      dh_installdebconf       
-       dh_installdocs
-#      dh_installmenu
-#      dh_installlogrotate
-#      dh_installemacsen
-#      dh_installpam
-#      dh_installmime
-#      dh_installinit
-#      dh_installcron
-#      dh_installman
-#      dh_installinfo
-#      dh_undocumented
-       dh_installchangelogs
-       dh_strip
-       dh_compress
-       dh_fixperms
-#      dh_makeshlibs
-       dh_installdeb
-#      dh_perl
-       dh_shlibdeps
-       dh_gencontrol
-       dh_md5sums
-       dh_builddeb
+       dh_testdir -a
+       dh_testroot -a
+       dh_installdocs -a
+       dh_installchangelogs -a
+       dh_strip -a
+       dh_compress -a
+       dh_fixperms -a
+       dh_installdeb -a
+       dh_shlibdeps -a
+       dh_gencontrol -a
+       dh_md5sums -a
+       dh_builddeb -a
 
 binary: binary-indep binary-arch
 .PHONY: build clean binary-indep binary-arch binary install configure