r11711: fix build-twice-in-a-row
[cl-readline.git] / debian / rules
index 5f9dab6f92fe38b24c528ba5633fbe1a76e2a377..5f75dc03796a1815d3a1fc8594e65e0f58bd071f 100755 (executable)
@@ -32,6 +32,7 @@ clean:
        rm -f build-stamp configure-stamp
        # Add here commands to clean up after the build process.
        rm -f debian/$(debpkg).postinst.* debian/$(debpkg).prerm.*
+       rm -f *.o *.so
        dh_clean
 
 install: build
@@ -42,7 +43,7 @@ install: build
        dh_installdirs $(clc-systems) $(clc-files) $(clc-tests)
        dh_install $(pkg).asd $(source-files) $(clc-files)
        dh_link $(clc-files)/$(pkg).asd $(clc-systems)/$(pkg).asd
-       dh_install "libreadline-cl.so" $(lib-dir)
+       dh_install *.so $(lib-dir)
 
 # Build architecture-independent files here.
 binary-indep: build install