Convert to dh-lisp; add Vcs-Browser
[getopt.git] / debian / rules
index a99f8172e9b8ebf4ab656d5eac5a41db105b325c..6d951b1fc56dcc24e10b9076824489fe15e36884 100755 (executable)
@@ -1,7 +1,7 @@
 #!/usr/bin/make -f
 
-pkg    := getopt
-debpkg  := cl-$(pkg)
+pkg            := getopt
+debpkg         := cl-$(pkg)
 
 clc-source     := usr/share/common-lisp/source
 clc-systems    := usr/share/common-lisp/systems
@@ -10,46 +10,38 @@ clc-tests   := $(clc-source)/$(pkg-tests)
 doc-dir                := usr/share/doc/$(debpkg)
 source-files   := $(wildcard *.lisp)
 
-configure: configure-stamp
-configure-stamp:
-       dh_testdir
-       touch configure-stamp
-
-build: build-stamp
 
-build-stamp: configure-stamp 
-       dh_testdir
-       touch build-stamp
+build:
 
 clean:
        dh_testdir
        dh_testroot
-       rm -f build-stamp configure-stamp
-       rm -f debian/$(debpkg).postinst.* debian/$(debpkg).prerm.*
        dh_clean
 
 install: build
        dh_testdir
        dh_testroot
        dh_prep
-       dh_installdirs $(clc-systems) $(clc-files) $(clc-tests)
-       dh_install $(pkg).asd $(source-files) $(clc-files)
-       dh_link $(clc-files)/$(pkg).asd $(clc-systems)/$(pkg).asd
-
-binary-indep: build install
-       dh_testdir -i
-       dh_testroot -i
-       dh_installdocs -i
-       dh_installchangelogs -i
-       dh_strip -i
-       dh_compress -i
-       dh_fixperms -i
-       dh_installdeb -i
-       dh_gencontrol -i
-       dh_md5sums -i
-       dh_builddeb -i
-
-binary-arch: build install
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install configure
+       dh_installdirs
+       dh_install $(pkg).asd $(clc-files)
+       dh_install *.lisp $(clc-files)
+
+binary-indep: install
+       dh_testdir
+       dh_testroot
+       dh_installdocs
+       dh_installchangelogs
+       dh_lisp
+       dh_compress
+       dh_fixperms
+       dh_installdeb
+       dh_gencontrol
+       dh_md5sums
+       dh_builddeb
+
+binary-arch:
+
+binary: binary-indep
+
+
+.PHONY: build clean binary-indep binary-arch binary install