apply patches from Daniel Janus
[getopt.git] / debian / rules
index 2c459683aa18058ce37d08b98b06e520c4607e95..9ff92d18b7d49449489c45bbe028d20785317784 100755 (executable)
@@ -14,8 +14,6 @@ source-files  := $(wildcard *.lisp)
 configure: configure-stamp
 configure-stamp:
        dh_testdir
-       # Add here commands to configure the package.
-
        touch configure-stamp
 
 
@@ -23,14 +21,13 @@ build: build-stamp
 
 build-stamp: configure-stamp 
        dh_testdir
-       # Add here commands to compile the package.
        touch build-stamp
 
 clean:
        dh_testdir
        dh_testroot
        rm -f build-stamp configure-stamp
-       # Add here commands to clean up after the build process.
+       # Clean up after the build process.
        rm -f debian/$(debpkg).postinst.* debian/$(debpkg).prerm.*
        dh_clean
 
@@ -38,43 +35,29 @@ install: build
        dh_testdir
        dh_testroot
        dh_clean -k
-       # Add here commands to install the package into debian/getopt.
+       # Install the package into debian/getopt.
        dh_installdirs $(clc-systems) $(clc-files) $(clc-tests)
        dh_install $(pkg).asd $(source-files) $(clc-files)
        dh_link $(clc-files)/$(pkg).asd $(clc-systems)/$(pkg).asd
 
-# Build architecture-independent files here.
+# Build architecture-independent files
 binary-indep: build install
-
-
-# Build architecture-dependent files here.
-binary-arch: build install
        dh_testdir
        dh_testroot
-#      dh_installdebconf       
        dh_installdocs
-#      dh_installmenu
-#      dh_installlogrotate
-#      dh_installemacsen
-#      dh_installpam
-#      dh_installmime
-#      dh_installinit
-#      dh_installcron
-#      dh_installman
-#      dh_installinfo
-#      dh_undocumented
        dh_installchangelogs
        dh_strip
        dh_compress
        dh_fixperms
-#      dh_makeshlibs
        dh_installdeb
-#      dh_perl
        dh_shlibdeps
        dh_gencontrol
        dh_md5sums
        dh_builddeb
 
+# Build architecture-dependent files
+binary-arch: build install
+
 binary: binary-indep binary-arch
 .PHONY: build clean binary-indep binary-arch binary install configure