Updates for new debian standards debian-1.2.0-2
authorKevin Rosenberg <kevin@rosenberg.net>
Sun, 2 Aug 2009 10:30:48 +0000 (04:30 -0600)
committerKevin Rosenberg <kevin@rosenberg.net>
Sun, 2 Aug 2009 10:30:48 +0000 (04:30 -0600)
debian/changelog
debian/compat
debian/control
debian/postinst
debian/prerm
debian/rules
debian/watch [new file with mode: 0644]

index 39546357466e8d704bb917ab4f1ea09742c063ad..a1dfc65201ed758e91b60d5f5ccd75e520670c8d 100644 (file)
@@ -1,3 +1,14 @@
+cl-getopt (1.2.0-2) unstable; urgency=low
+
+  * debian/watch: New file
+  * debian/control: Require debhelper 7. Change to new lisp section.
+  Add Vcs-Git and Homepage fields.
+  * debian/compat: Update to version 7
+  * debian/rules: Update for debhelper 7, architecture-independent build
+  * debian/{prerm,postrm}: Remove path from binary function
+
+ -- Kevin M. Rosenberg <kmr@debian.org>  Sun, 02 Aug 2009 04:30:20 -0600
+
 cl-getopt (1.2.0-1) unstable; urgency=low
 
   * New upstream
index b8626c4cff2849624fb67f87cd0ad72b163671ad..7f8f011eb73d6043d2e6db9d2c101195ae2801f2 100644 (file)
@@ -1 +1 @@
-4
+7
index 8708de9ecfafa16ad8d16452a90510e8447190d3..7c86ec6bef7c04792da3c83c8c1475aeec1348b7 100644 (file)
@@ -1,13 +1,15 @@
 Source: cl-getopt
-Section: devel
+Section: lisp
 Priority: optional
 Maintainer: Kevin M. Rosenberg <kmr@debian.org>
-Build-Depends: debhelper (>= 4.0.0)
-Standards-Version: 3.7.3.0
+Build-Depends: debhelper (>= 7.0.0)
+Standards-Version: 3.8.2.0
+Homepage: http://files.b9.com/getopt/
+Vcs-Git: git://git.b9.com/getopt.git
 
 Package: cl-getopt
 Architecture: all
-Depends: ${shlibs:Depends}, common-lisp-controller, cl-ptester
+Depends: common-lisp-controller, cl-ptester
 Description: Common Lisp utility for command-line processing
  This package provides Common Lisp programs processing of command-line
  arguments. The command-line processing is based on GNU's getopt_long
index b17dbde92056868a39552a2849fb26cb62eaa264..40e672f8d2d65e85f3174c7f29eb7dad301697c4 100755 (executable)
@@ -3,27 +3,9 @@ set -e
 
 LISP_PKG=getopt
 
-# summary of how this script can be called:
-#        * <postinst> `configure' <most-recently-configured-version>
-#        * <old-postinst> `abort-upgrade' <new version>
-#        * <conflictor's-postinst> `abort-remove' `in-favour' <package>
-#          <new-version>
-#        * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
-#          <failed-install-package> <version> `removing'
-#          <conflicting-package> <version>
-# for details, see http://www.debian.org/doc/debian-policy/ or
-# the debian-policy package
-#
-# quoting from the policy:
-#     Any necessary prompting should almost always be confined to the
-#     post-installation script, and should be protected with a conditional
-#     so that unnecessary prompting doesn't happen if a package's
-#     installation fails and the `postinst' is called with `abort-upgrade',
-#     `abort-remove' or `abort-deconfigure'.
-
 case "$1" in
     configure)
-       /usr/sbin/register-common-lisp-source ${LISP_PKG}
+       register-common-lisp-source ${LISP_PKG}
        ;;
     abort-upgrade|abort-remove|abort-deconfigure)
        ;;
@@ -33,9 +15,6 @@ case "$1" in
        ;;
 esac
 
-# dh_installdeb will replace this with shell code automatically
-# generated by other debhelper scripts.
-
 #DEBHELPER#
 
 exit 0
index e711eee6d04ef9668534a270e92c6cb39f1485f2..92ca7f04ab3cfc2110a4eb98a74ba0c2160ef8ba 100755 (executable)
@@ -3,21 +3,9 @@ set -e
 
 LISP_PKG=getopt
 
-# summary of how this script can be called:
-#        * <prerm> `remove'
-#        * <old-prerm> `upgrade' <new-version>
-#        * <new-prerm> `failed-upgrade' <old-version>
-#        * <conflictor's-prerm> `remove' `in-favour' <package> <new-version>
-#        * <deconfigured's-prerm> `deconfigure' `in-favour'
-#          <package-being-installed> <version> `removing'
-#          <conflicting-package> <version>
-# for details, see http://www.debian.org/doc/debian-policy/ or
-# the debian-policy package
-
-
 case "$1" in
     remove|upgrade|deconfigure)
-       /usr/sbin/unregister-common-lisp-source ${LISP_PKG}
+       unregister-common-lisp-source ${LISP_PKG}
         ;;
     failed-upgrade)
         ;;
@@ -27,9 +15,6 @@ case "$1" in
     ;;
 esac
 
-# dh_installdeb will replace this with shell code automatically
-# generated by other debhelper scripts.
-
 #DEBHELPER#
 
 exit 0
index 9ff92d18b7d49449489c45bbe028d20785317784..a99f8172e9b8ebf4ab656d5eac5a41db105b325c 100755 (executable)
@@ -8,7 +8,6 @@ clc-systems     := usr/share/common-lisp/systems
 clc-files      := $(clc-source)/$(pkg)
 clc-tests      := $(clc-source)/$(pkg-tests)
 doc-dir                := usr/share/doc/$(debpkg)
-
 source-files   := $(wildcard *.lisp)
 
 configure: configure-stamp
@@ -16,7 +15,6 @@ configure-stamp:
        dh_testdir
        touch configure-stamp
 
-
 build: build-stamp
 
 build-stamp: configure-stamp 
@@ -27,37 +25,31 @@ clean:
        dh_testdir
        dh_testroot
        rm -f build-stamp configure-stamp
-       # Clean up after the build process.
        rm -f debian/$(debpkg).postinst.* debian/$(debpkg).prerm.*
        dh_clean
 
 install: build
        dh_testdir
        dh_testroot
-       dh_clean -k
-       # Install the package into debian/getopt.
+       dh_prep
        dh_installdirs $(clc-systems) $(clc-files) $(clc-tests)
        dh_install $(pkg).asd $(source-files) $(clc-files)
        dh_link $(clc-files)/$(pkg).asd $(clc-systems)/$(pkg).asd
 
-# Build architecture-independent files
 binary-indep: build install
-       dh_testdir
-       dh_testroot
-       dh_installdocs
-       dh_installchangelogs
-       dh_strip
-       dh_compress
-       dh_fixperms
-       dh_installdeb
-       dh_shlibdeps
-       dh_gencontrol
-       dh_md5sums
-       dh_builddeb
-
-# Build architecture-dependent files
+       dh_testdir -i
+       dh_testroot -i
+       dh_installdocs -i
+       dh_installchangelogs -i
+       dh_strip -i
+       dh_compress -i
+       dh_fixperms -i
+       dh_installdeb -i
+       dh_gencontrol -i
+       dh_md5sums -i
+       dh_builddeb -i
+
 binary-arch: build install
 
 binary: binary-indep binary-arch
 .PHONY: build clean binary-indep binary-arch binary install configure
-
diff --git a/debian/watch b/debian/watch
new file mode 100644 (file)
index 0000000..6c920b2
--- /dev/null
@@ -0,0 +1,3 @@
+version=3
+http://files.b9.com/getopt/getopt-([\d\.]*)\.tar\.gz
+