Updates for new debian standards
[hyperobject.git] / debian / rules
index 80d3568c28391674ac39cb20b84189b850b12669..0757650fb0e51914a1b094808784d53a950e1587 100755 (executable)
@@ -1,80 +1,60 @@
 #!/usr/bin/make -f
 
-export DH_COMPAT=4
-
-pkg    := hyperobject
-debpkg  := cl-hyperobject
-
+pkg      := hyperobject
+pkg-tests := $(pkg)-tests
+debpkg    := cl-$(pkg)
 
 clc-source     := usr/share/common-lisp/source
 clc-systems    := usr/share/common-lisp/systems
-clc-hyperobject        := $(clc-source)/$(pkg)
-
+clc-files      := $(clc-source)/$(pkg)
+clc-tests      := $(clc-source)/$(pkg-tests)
 doc-dir                := usr/share/doc/$(debpkg)
 
+tests-files    := tests.lisp
+source-files   := $(filter-out $(tests-files),$(wildcard *.lisp))
 
 configure: configure-stamp
 configure-stamp:
        dh_testdir
-       # Add here commands to configure the package.
-
        touch configure-stamp
 
-
 build: build-stamp
 
 build-stamp: configure-stamp 
        dh_testdir
-       # Add here commands to compile the package.
        touch build-stamp
 
 clean:
        dh_testdir
        dh_testroot
        rm -f build-stamp configure-stamp
-       # Add here commands to clean up after the build process.
-       rm -f debian/cl-hyperobject.postinst.* debian/cl-hyperobject.prerm.*
+       rm -f debian/$(debpkg).postinst.* debian/$(debpkg).prerm.*
        dh_clean
 
 install: build
        dh_testdir
        dh_testroot
-       dh_clean -k
-       # Add here commands to install the package into debian/hyperobject.
-       dh_installdirs $(clc-systems) $(clc-hyperobject) $(doc-dir)
-       dh_install hyperobject.asd $(wildcard *.lisp) $(clc-hyperobject)
-       dh_link $(clc-hyperobject)/hyperobject.asd $(clc-systems)/hyperobject.asd
+       dh_prep
+       dh_installdirs $(clc-systems) $(clc-files) $(doc-dir) $(clc-tests)
+       dh_install $(pkg).asd $(source-files) $(clc-files)
+       dh_link $(clc-files)/$(pkg).asd $(clc-systems)/$(pkg).asd
+       dh_install $(pkg-tests).asd $(tests-files) $(clc-tests)
+       dh_link $(clc-tests)/$(pkg-tests).asd $(clc-systems)/$(pkg-tests).asd
 
-# Build architecture-independent files here.
 binary-indep: build install
        dh_testdir -i 
        dh_testroot -i
-#      dh_installdebconf       
        dh_installdocs -i
-       dh_installexamples -i $(wilcard examples/example*.lisp)
-#      dh_installmenu
-#      dh_installlogrotate
-#      dh_installemacsen
-#      dh_installpam
-#      dh_installmime
-#      dh_installinit
-#      dh_installcron
-#      dh_installman
-#      dh_installinfo
-#      dh_undocumented
+       dh_installexamples -i $(wilcard examples/*.lisp)
        dh_installchangelogs -i
        dh_strip -i
        dh_compress -i
        dh_fixperms -i
-#      dh_makeshlibs
        dh_installdeb -i
-#      dh_perl
-       dh_shlibdeps -i
        dh_gencontrol -i
        dh_md5sums -i
        dh_builddeb -i
 
-# Build architecture-dependent files here.
 binary-arch: build install
 
 binary: binary-indep binary-arch