r4664: *** empty log message ***
[hyperobject.git] / debian / rules
index 80d3568c28391674ac39cb20b84189b850b12669..bb89106b60e9bdb4007e9d267c96bbb8d21f9693 100755 (executable)
@@ -2,16 +2,19 @@
 
 export DH_COMPAT=4
 
-pkg    := hyperobject
-debpkg  := cl-hyperobject
+pkg      := hyperobject
+pkg-tests := $(pkg)-tests
+debpkg    := cl-$(pkg)
 
 
 clc-source     := usr/share/common-lisp/source
 clc-systems    := usr/share/common-lisp/systems
-clc-hyperobject        := $(clc-source)/$(pkg)
-
+clc-files      := $(clc-source)/$(pkg)
+clc-tests      := $(clc-source)/$(pkg-tests)
 doc-dir                := usr/share/doc/$(debpkg)
 
+tests-files    := tests.lisp
+source-files   := $(filter-out $(tests-files),$(wildcard *.lisp))
 
 configure: configure-stamp
 configure-stamp:
@@ -41,9 +44,11 @@ install: build
        dh_testroot
        dh_clean -k
        # Add here commands to install the package into debian/hyperobject.
-       dh_installdirs $(clc-systems) $(clc-hyperobject) $(doc-dir)
-       dh_install hyperobject.asd $(wildcard *.lisp) $(clc-hyperobject)
-       dh_link $(clc-hyperobject)/hyperobject.asd $(clc-systems)/hyperobject.asd
+       dh_installdirs $(clc-systems) $(clc-files) $(doc-dir) $(clc-tests)
+       dh_install $(pkg).asd $(source-files) $(clc-files)
+       dh_link $(clc-files)/$(pkg).asd $(clc-systems)/$(pkg).asd
+       dh_install $(pkg-tests).asd $(tests-files) $(clc-tests)
+       dh_link $(clc-tests)/$(pkg-tests).asd $(clc-systems)/$(pkg-tests).asd
 
 # Build architecture-independent files here.
 binary-indep: build install
@@ -51,7 +56,7 @@ binary-indep: build install
        dh_testroot -i
 #      dh_installdebconf       
        dh_installdocs -i
-       dh_installexamples -i $(wilcard examples/example*.lisp)
+       dh_installexamples -i $(wilcard examples/*.lisp)
 #      dh_installmenu
 #      dh_installlogrotate
 #      dh_installemacsen