Fix lintian warnings
[hyperobject.git] / debian / rules
index 66e1069b4c441bbb01802b2731778e7e5873729f..deaab4591033da46d661510128870b4b306975ca 100755 (executable)
@@ -1,82 +1,54 @@
 #!/usr/bin/make -f
 
-export DH_COMPAT=4
-
-pkg    := hyperobject
-debpkg  := cl-hyperobject
-
+pkg            := hyperobject
+pkg-tests      := $(pkg)-tests
+debpkg         := cl-$(pkg)
 
 clc-source     := usr/share/common-lisp/source
 clc-systems    := usr/share/common-lisp/systems
-clc-hyperobject        := $(clc-source)/$(pkg)
-
-doc-dir                := usr/share/doc/$(debpkg)
-
+clc-files      := $(clc-source)/$(pkg)
+clc-tests      := $(clc-source)/$(pkg-tests)
 
-configure: configure-stamp
-configure-stamp:
-       dh_testdir
-       # Add here commands to configure the package.
+tests-files    := tests.lisp
+source-files   := $(filter-out $(tests-files),$(wildcard *.lisp))
 
-       touch configure-stamp
 
+build: build-arch build-indep
 
-build: build-stamp
+build-arch:
 
-build-stamp: configure-stamp 
-       dh_testdir
-       # Add here commands to compile the package.
-       touch build-stamp
+build-indep:
 
 clean:
        dh_testdir
        dh_testroot
-       rm -f build-stamp configure-stamp
-       # Add here commands to clean up after the build process.
-       rm -f debian/cl-hyperobject.postinst.* debian/cl-hyperobject.prerm.*
        dh_clean
 
 install: build
        dh_testdir
        dh_testroot
-       dh_clean -k
-       # Add here commands to install the package into debian/hyperobject.
-       dh_installdirs $(clc-systems) $(clc-hyperobject) $(doc-dir)
-       dh_install hyperobject.asd $(shell echo *.lisp) $(clc-hyperobject)
-       dh_link $(clc-hyperobject)/hyperobject.asd $(clc-systems)/hyperobject.asd
+       dh_prep
+       dh_installdirs
+       dh_install $(pkg).asd $(source-files) $(clc-files)
+       dh_install $(pkg-tests).asd $(tests-files) $(clc-tests)
+
+binary-indep: install
+       dh_testdir
+       dh_testroot 
+       dh_installdocs 
+       dh_installexamples examples/*.lisp
+       dh_installchangelogs 
+       dh_lisp
+       dh_compress 
+       dh_fixperms 
+       dh_installdeb 
+       dh_gencontrol 
+       dh_md5sums 
+       dh_builddeb 
 
-# Build architecture-independent files here.
-binary-indep: build install
-       dh_testdir -i 
-       dh_testroot -i
-#      dh_installdebconf       
-       dh_installdocs -i
-#      dh_installexamples -i hyperobject-example.lisp
-#      dh_installmenu
-#      dh_installlogrotate
-#      dh_installemacsen
-#      dh_installpam
-#      dh_installmime
-#      dh_installinit
-#      dh_installcron
-#      dh_installman
-#      dh_installinfo
-#      dh_undocumented
-       dh_installchangelogs -i
-       dh_strip -i
-       dh_compress -i
-       dh_fixperms -i
-#      dh_makeshlibs
-       dh_installdeb -i
-#      dh_perl
-       dh_shlibdeps -i
-       dh_gencontrol -i
-       dh_md5sums -i
-       dh_builddeb -i
+binary-arch:
 
-# Build architecture-dependent files here.
-binary-arch: build install
+binary: binary-indep
 
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install configure
 
+.PHONY: build clean binary-indep binary-arch binary install