update to debhelper 7
[kmrcl.git] / debian / rules
index fa61826c78996f16eb30d4f17f0d60451f2852e7..3a37821e527f62dbb75f454eb29a46055c88870c 100755 (executable)
@@ -1,17 +1,17 @@
 #!/usr/bin/make -f
 
-export DH_COMPAT=4
-
 pkg    := kmrcl
-debpkg  := cl-kmrcl
-
+pkg-tests := $(pkg)-tests
+debpkg  := cl-$(pkg)
 
 clc-source     := usr/share/common-lisp/source
 clc-systems    := usr/share/common-lisp/systems
-clc-kmrcl      := $(clc-source)/$(pkg)
-
+clc-files      := $(clc-source)/$(pkg)
+clc-tests      := $(clc-source)/$(pkg-tests)
 doc-dir                := usr/share/doc/$(debpkg)
 
+tests-files    := tests.lisp
+source-files   := $(filter-out $(tests-files),$(wildcard *.lisp))
 
 configure: configure-stamp
 configure-stamp:
@@ -33,50 +33,38 @@ clean:
        dh_testroot
        rm -f build-stamp configure-stamp
        # Add here commands to clean up after the build process.
-       rm -f debian/cl-kmrcl.postinst.* debian/cl-kmrcl.prerm.*
+       rm -f debian/$(debpkg).postinst.* debian/$(debpkg).prerm.*
        dh_clean
 
 install: build
        dh_testdir
        dh_testroot
-       dh_clean -k
+       dh_prep
        # Add here commands to install the package into debian/kmrcl.
-       dh_installdirs $(clc-systems) $(clc-kmrcl) $(doc-dir)
-       dh_install kmrcl.asd $(shell echo *.lisp) $(clc-kmrcl)
-       dh_link $(clc-kmrcl)/kmrcl.asd $(clc-systems)/kmrcl.asd
+       dh_installdirs $(clc-systems) $(clc-files) $(clc-tests)
+       dh_install $(pkg).asd $(source-files) $(clc-files)
+       dh_link $(clc-files)/$(pkg).asd $(clc-systems)/$(pkg).asd
+       dh_install $(pkg-tests).asd $(tests-files) $(clc-tests)
+       dh_link $(clc-tests)/$(pkg-tests).asd $(clc-systems)/$(pkg-tests).asd
 
 # Build architecture-independent files here.
 binary-indep: build install
-
-
-# Build architecture-dependent files here.
-binary-arch: build install
        dh_testdir
        dh_testroot
-#      dh_installdebconf       
        dh_installdocs
-#      dh_installmenu
-#      dh_installlogrotate
-#      dh_installemacsen
-#      dh_installpam
-#      dh_installmime
-#      dh_installinit
-#      dh_installcron
-#      dh_installman
-#      dh_installinfo
-#      dh_undocumented
-       dh_installchangelogs
+       dh_installchangelogs ChangeLog
        dh_strip
        dh_compress
        dh_fixperms
-#      dh_makeshlibs
        dh_installdeb
-#      dh_perl
        dh_shlibdeps
        dh_gencontrol
        dh_md5sums
        dh_builddeb
 
+# Build architecture-dependent files here.
+binary-arch: build install
+
 binary: binary-indep binary-arch
 .PHONY: build clean binary-indep binary-arch binary install configure