Add recommended targets to debian/rules
[kmrcl.git] / debian / rules
index 2bc2c46eb6b089c602d0a4fb1732999177084725..8ee6693af07db128624ee3ccd96b6cea3ee29eb1 100755 (executable)
@@ -1,83 +1,53 @@
 #!/usr/bin/make -f
 
-pkg    := kmrcl
-pkg-tests := $(pkg)-tests
-debpkg  := cl-$(pkg)
+pkg            := kmrcl
+pkg-tests      := $(pkg)-tests
+debpkg         := cl-$(pkg)
 
 clc-source     := usr/share/common-lisp/source
 clc-systems    := usr/share/common-lisp/systems
 clc-files      := $(clc-source)/$(pkg)
 clc-tests      := $(clc-source)/$(pkg-tests)
-doc-dir                := usr/share/doc/$(debpkg)
 
 tests-files    := tests.lisp
 source-files   := $(filter-out $(tests-files),$(wildcard *.lisp))
 
-configure: configure-stamp
-configure-stamp:
-       dh_testdir
-       # Add here commands to configure the package.
-
-       touch configure-stamp
 
+build: build-arch build-indep
 
-build: build-stamp
+build-arch:
 
-build-stamp: configure-stamp 
-       dh_testdir
-       # Add here commands to compile the package.
-       touch build-stamp
+build-indep:
 
 clean:
        dh_testdir
        dh_testroot
-       rm -f build-stamp configure-stamp
-       # Add here commands to clean up after the build process.
-       rm -f debian/$(debpkg).postinst.* debian/$(debpkg).prerm.*
        dh_clean
 
 install: build
        dh_testdir
        dh_testroot
-       dh_clean -k
-       # Add here commands to install the package into debian/kmrcl.
-       dh_installdirs $(clc-systems) $(clc-files) $(clc-tests)
+       dh_prep
+       dh_installdirs
        dh_install $(pkg).asd $(source-files) $(clc-files)
-       dh_link $(clc-files)/$(pkg).asd $(clc-systems)/$(pkg).asd
        dh_install $(pkg-tests).asd $(tests-files) $(clc-tests)
-       dh_link $(clc-tests)/$(pkg-tests).asd $(clc-systems)/$(pkg-tests).asd
 
-# Build architecture-independent files here.
-binary-indep: build install
+binary-indep: install
        dh_testdir
        dh_testroot
-#      dh_installdebconf       
        dh_installdocs
-#      dh_installmenu
-#      dh_installlogrotate
-#      dh_installemacsen
-#      dh_installpam
-#      dh_installmime
-#      dh_installinit
-#      dh_installcron
-#      dh_installman
-#      dh_installinfo
-#      dh_undocumented
-       dh_installchangelogs ChangeLog
-       dh_strip
+       dh_installchangelogs
+       dh_lisp
        dh_compress
        dh_fixperms
-#      dh_makeshlibs
        dh_installdeb
-#      dh_perl
-       dh_shlibdeps
        dh_gencontrol
        dh_md5sums
        dh_builddeb
 
-# Build architecture-dependent files here.
-binary-arch: build install
+binary-arch:
+
+binary: binary-indep
 
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install configure
 
+.PHONY: build clean binary-indep binary-arch binary install