debian update
[kmrcl.git] / debian / rules
index cf07a520165278c887def0f2baf252c9931ce396..c0b8fb12d910877ea45301dccd242f6e1165396b 100755 (executable)
@@ -1,32 +1,33 @@
 #!/usr/bin/make -f
 
 pkg            := kmrcl
-pkg-tests      := $(pkg)-tests
 debpkg         := cl-$(pkg)
 
 clc-source     := usr/share/common-lisp/source
 clc-systems    := usr/share/common-lisp/systems
 clc-files      := $(clc-source)/$(pkg)
-clc-tests      := $(clc-source)/$(pkg-tests)
 
 tests-files    := tests.lisp
 source-files   := $(filter-out $(tests-files),$(wildcard *.lisp))
 
 
-build:
+build: build-arch build-indep
+
+build-arch:
+
+build-indep:
 
 clean:
        dh_testdir
        dh_testroot
-       dh_clean
+       dh_clean .bin/
 
 install: build
        dh_testdir
        dh_testroot
        dh_prep
        dh_installdirs
-       dh_install $(pkg).asd $(source-files) $(clc-files)
-       dh_install $(pkg-tests).asd $(tests-files) $(clc-tests)
+       dh_install $(pkg).asd $(source-files) ${test-files} $(clc-files)
 
 binary-indep: install
        dh_testdir