Add recommended targets to debian/rules
[kmrcl.git] / debian / rules
index fa61826c78996f16eb30d4f17f0d60451f2852e7..8ee6693af07db128624ee3ccd96b6cea3ee29eb1 100755 (executable)
@@ -1,82 +1,53 @@
 #!/usr/bin/make -f
 
-export DH_COMPAT=4
-
-pkg    := kmrcl
-debpkg  := cl-kmrcl
-
+pkg            := kmrcl
+pkg-tests      := $(pkg)-tests
+debpkg         := cl-$(pkg)
 
 clc-source     := usr/share/common-lisp/source
 clc-systems    := usr/share/common-lisp/systems
-clc-kmrcl      := $(clc-source)/$(pkg)
-
-doc-dir                := usr/share/doc/$(debpkg)
+clc-files      := $(clc-source)/$(pkg)
+clc-tests      := $(clc-source)/$(pkg-tests)
 
+tests-files    := tests.lisp
+source-files   := $(filter-out $(tests-files),$(wildcard *.lisp))
 
-configure: configure-stamp
-configure-stamp:
-       dh_testdir
-       # Add here commands to configure the package.
-
-       touch configure-stamp
 
+build: build-arch build-indep
 
-build: build-stamp
+build-arch:
 
-build-stamp: configure-stamp 
-       dh_testdir
-       # Add here commands to compile the package.
-       touch build-stamp
+build-indep:
 
 clean:
        dh_testdir
        dh_testroot
-       rm -f build-stamp configure-stamp
-       # Add here commands to clean up after the build process.
-       rm -f debian/cl-kmrcl.postinst.* debian/cl-kmrcl.prerm.*
        dh_clean
 
 install: build
        dh_testdir
        dh_testroot
-       dh_clean -k
-       # Add here commands to install the package into debian/kmrcl.
-       dh_installdirs $(clc-systems) $(clc-kmrcl) $(doc-dir)
-       dh_install kmrcl.asd $(shell echo *.lisp) $(clc-kmrcl)
-       dh_link $(clc-kmrcl)/kmrcl.asd $(clc-systems)/kmrcl.asd
-
-# Build architecture-independent files here.
-binary-indep: build install
-
+       dh_prep
+       dh_installdirs
+       dh_install $(pkg).asd $(source-files) $(clc-files)
+       dh_install $(pkg-tests).asd $(tests-files) $(clc-tests)
 
-# Build architecture-dependent files here.
-binary-arch: build install
+binary-indep: install
        dh_testdir
        dh_testroot
-#      dh_installdebconf       
        dh_installdocs
-#      dh_installmenu
-#      dh_installlogrotate
-#      dh_installemacsen
-#      dh_installpam
-#      dh_installmime
-#      dh_installinit
-#      dh_installcron
-#      dh_installman
-#      dh_installinfo
-#      dh_undocumented
        dh_installchangelogs
-       dh_strip
+       dh_lisp
        dh_compress
        dh_fixperms
-#      dh_makeshlibs
        dh_installdeb
-#      dh_perl
-       dh_shlibdeps
        dh_gencontrol
        dh_md5sums
        dh_builddeb
 
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install configure
+binary-arch:
+
+binary: binary-indep
+
 
+.PHONY: build clean binary-indep binary-arch binary install