new version 1.98
[kmrcl.git] / debian / rules
index fa61826c78996f16eb30d4f17f0d60451f2852e7..9abb12ad68ec9672ab43b2a2364cd0f3752e95df 100755 (executable)
@@ -1,17 +1,17 @@
 #!/usr/bin/make -f
 
-export DH_COMPAT=4
-
 pkg    := kmrcl
-debpkg  := cl-kmrcl
-
+pkg-tests := $(pkg)-tests
+debpkg  := cl-$(pkg)
 
 clc-source     := usr/share/common-lisp/source
 clc-systems    := usr/share/common-lisp/systems
-clc-kmrcl      := $(clc-source)/$(pkg)
-
+clc-files      := $(clc-source)/$(pkg)
+clc-tests      := $(clc-source)/$(pkg-tests)
 doc-dir                := usr/share/doc/$(debpkg)
 
+tests-files    := tests.lisp
+source-files   := $(filter-out $(tests-files),$(wildcard *.lisp))
 
 configure: configure-stamp
 configure-stamp:
@@ -33,7 +33,7 @@ clean:
        dh_testroot
        rm -f build-stamp configure-stamp
        # Add here commands to clean up after the build process.
-       rm -f debian/cl-kmrcl.postinst.* debian/cl-kmrcl.prerm.*
+       rm -f debian/$(debpkg).postinst.* debian/$(debpkg).prerm.*
        dh_clean
 
 install: build
@@ -41,9 +41,11 @@ install: build
        dh_testroot
        dh_clean -k
        # Add here commands to install the package into debian/kmrcl.
-       dh_installdirs $(clc-systems) $(clc-kmrcl) $(doc-dir)
-       dh_install kmrcl.asd $(shell echo *.lisp) $(clc-kmrcl)
-       dh_link $(clc-kmrcl)/kmrcl.asd $(clc-systems)/kmrcl.asd
+       dh_installdirs $(clc-systems) $(clc-files) $(clc-tests)
+       dh_install $(pkg).asd $(source-files) $(clc-files)
+       dh_link $(clc-files)/$(pkg).asd $(clc-systems)/$(pkg).asd
+       dh_install $(pkg-tests).asd $(tests-files) $(clc-tests)
+       dh_link $(clc-tests)/$(pkg-tests).asd $(clc-systems)/$(pkg-tests).asd
 
 # Build architecture-independent files here.
 binary-indep: build install
@@ -65,7 +67,7 @@ binary-arch: build install
 #      dh_installman
 #      dh_installinfo
 #      dh_undocumented
-       dh_installchangelogs
+       dh_installchangelogs ChangeLog
        dh_strip
        dh_compress
        dh_fixperms